OMV 5 on Acer AC100 microserver

  • Hi everyone,


    I present you briefly my installation, and what i did to make it work better.


    I used for a long time a Netgear readynas ultra 4 (single core atom cpu), tweaked to 2GB RAM.

    When a corrupted OS partition (4GB raid 1 partition) bricked my nas last year (hopefully restored via Telnet access), it was time that i implement better hardware and software.


    As the HP gen8 microserver are more expensive used than they were new, i stumbled on a Acer AC100 (similar to a gen8 microserver, but with sandy bridge architecture, and no usb3) at 110€ with 2*2TB drives. 8)


    And here comes the things that didn't work well :

    • 1 drive wasn't available, the seller proposed to replace it with 3 1TB drive, i accepted.
    • upon receiving the nas, the 3 1TB drive couldn't fully enter the rack. I discovered at that moment that the disks are SAS drives and not SATA => i have 3 more paperweights :rolleyes:
    • the default cpu was a pentium G645 (with 65W tdp). As used xeon low power doens't cost much nowadays, i wanted to install a Xeon E3-1225L => didn't work
    • i guessed the motherboard didn't support ivy bridge cpu (even though the intel C206 chipset is compatible), i then tried with a Xeon E3-1220L (sandy bridge) => didn't work either :cursing:
    • even after customizing the bios to add the microcode, it didn't work.

    I then realized Acer only wanted to accept the cpu it provided with the server, and hopefully, the Xeon E3-1260L was one of them, and it works like a charm now

    Next step was the RAM : i got 2*4GB ECC to replace the 2GB stock RAM (2*8GB was tempting but the price was a lot more).



    In the next post, i'll detail what i did to try to improve the array capacity, and what worked finally.



    After that, i got a 4 bays microserver with plenty of power, a 35W idle power consumption, running OMV5 on a 64GB USB stick.

  • Following the first hardware part, as i had 6 3TB drives total (4 from my old NAS, and 2 spares), for 4 SATA ports (and 1 eSATA) in the server, i tried to extend the capacity with a eSATA dual disk enclosure.


    It was too late when i discovered that the enclosure doesn't do the port multiplier function, but it had to be the eSATA itself...

    => i bought a PCIe->eSATA card which support the port multiplier function : it does, but it's unstable as hell due to the cheap ASMedia chispet used. As soon as the 2nd disk is called by the controller, it disappears... (at that time, i understood why people buy the LSI controllers).

    => in order to avoid discarding completely my idea, i looked for the C206 internal chipset compatibility with the PM function, and found one link saying that the 2 internal SATA3 ports should (not officially) be compatible.

    => i then bought both adapters for eSATA to SATA and back, to use the eSATA for an internal disk, and the SATA3 for the eSATA enclosure. It didn't work...


    At that moment, i finally accepted that i wouldn't manage to make it work, and thus bought 4*10TB disks, and used the 3TB in my previous NAS to use it as backup

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!