Unable to update - python error

  • I am unable to update my OMV4 and I have not been able to find this error in the forum. I know, I know, I really need to update to OMV5 and I do plan to but it will be a new box. Until then I want to keep this thing updated as much as possible. I tried the usual apt-clean, configure, update repositories with no luck. It seems to be complaining about Python.


  • vulcan4d

    Changed the title of the thread from “Unable to update” to “Unable to update - python error”.
  • The python error is not a problem. It has been posted about many, many times. The libelf1 package is in a bad state though. I would run omv-aptclean and see if it cleans it up. Otherwise, try:


    wget http://ftp.us.debian.org/debian/pool/main/e/elfutils/libelf1_0.168-1_amd64.deb

    sudo dpkg -i libelf1_0.168-1_amd64.deb

    omv 5.5.23 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The python error is not a problem. It has been posted about many, many times. The libelf1 package is in a bad state though. I would run omv-aptclean and see if it cleans it up. Otherwise, try:


    wget http://ftp.us.debian.org/debian/pool/main/e/elfutils/libelf1_0.168-1_amd64.deb

    sudo dpkg -i libelf1_0.168-1_amd64.deb

    Thank you for lending a helping hand. I did as you said, used app-clean which didn't work followed with re-installing the libelfl package. Sadly it too has the input/output error:


    Code
    sudo dpkg -i libelf1_0.168-1_amd64.deb
    dpkg: unrecoverable fatal error, aborting:
    reading files list for package 'libelf1:amd64': Input/output error

    I'll read up on libelf1 and see if I can find a solution.

  • Sounds as if the media your OS is installed on is starting to fail. What kind of media is it?

    omv 5.5.23 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!