OMV 5 ARM

  • Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Hardware: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - NanoPi M4 (v.1), backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user trying to convert to Linux on a HP dx2400, Debian 10 XFCE.

  • I have OMV 5.x installed on at least five arm64 systems right now. The install script in those docs has no problem with arm64.

    omv 5.5.23 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You need to take a closer look at the guide I linked to above. From the guide: “Installing OMV5 on Armbian Buster (Applies to most popular SBC models, the Odriods, Rock64, Renegade, NanoPi, BananaPi and several others.)

    “Armbian Buster” IS Debian 10 for ARM boards of 64 bit and 32 bit varieties. If you you are installing on a Raspberry as macom stated there is a guide in that link for that too.


    You deleted your original post! I’m done.

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Hardware: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - NanoPi M4 (v.1), backup - Odroid XU4, Pi-Hole (DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user trying to convert to Linux on a HP dx2400, Debian 10 XFCE.

  • it has, but that is not compatible with debian 10 as the salt version omv requires is deprecated, that guide only works with debain 9

    because i tired it last night and it didn't work?

    I rebuilt my R-PI4, a week or so ago (with the latest Raspberry PI OS) without an issue, and I did an Armbian build in the last few days. I've built several iterations of Debian 10 (Raspbian, Raspberry PI OS, and Armbian). Debian 10 + OMV works on SBC's.


    The script and supporting doc's work, but you'd have to follow the correct one for your device. Note that your regional software mirror might be the reason why your build failed. Try it again, preferably during weekdays. (Not weekends.)
    __________________________________________________________

    If you're trying to install the UEFI version of Debian's ARM64 distribution on an SBC, similar to -> this, you're on the wrong forum. That is not supported here.

  • I rebuilt my R-PI4, a week or so ago (with the latest Raspberry PI OS) without an issue, and I did an Armbian build in the last few days. I've built several iterations of Debian 10 (Raspbian, Raspberry PI OS, and Armbian). Debian 10 + OMV works on SBC's.


    The script and supporting doc's work, but you'd have to follow the correct one for your device. Note that your regional software mirror might be the reason why your build failed. Try it again, preferably during weekdays. (Not weekends.)
    __________________________________________________________

    If you're trying to install the UEFI version of Debian's ARM64 distribution on an SBC, similar to -> this, you're on the wrong forum. That is not supported here.

    think you are confused, i never said iterations of debian 10, i said debian 10. you can install actual Debian 10 on the raspberry pi 4 via https://raspi.debian.net/tested-images/ . OMV 5 install script does not work on debian 10 istelf, never mentioned raspbian. also i deleted the post because i found a working beta version of raspbian OS 64bit (full version not just a kernal switch) so i used that OS and then installed OMV 5 on that

    other forums showing issues of the install script not working on debian 10 are found here:

    https://github.com/saltstack/salt-bootstrap/issues/1353

  • other forums showing issues of the install script not working on debian 10 are found here:

    I don't see anything related to the install script on that thread. OMV doesn't use salt from the debian repos anyway. It uses packages from the OMV repo. - http://packages.openmediavault.org/public/pool/main/s/salt/

    OMV 5 install script does not work on debian 10 istelf,

    Maybe the non-official Debian image for the RPi doesn't work. I haven't tried it but I see little reason to use it over the very well supported Raspberry Pi OS (used to be Raspbian). And Armbian is Debian not an iteration (other than the kernel) and the install script works very well on arm64 for those images.

    omv 5.5.23 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.4.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I don't think I'm confused. I said "Iterations" in this context meaning "repetition of sequence". I've installed Debian 10 several times over the past year, on various platforms, using both 32bit and 64bit OS's and hardware.

    The differences between pure Debian 10 (Buster) and Raspbian, Raspberry PI OS and Armbian are tweaks and minor user-land variations. In any case, the document for 32 bit and Alternate 64bit installs is based on the Debian 10 net-install version which is pure Debian. OMV works fine when installed, by script, on these Debian 10 net-installs in both 32 and 64 bit. Further OMV is working fine on "tweaked" versions of Debian 10 (Raspberry PI OS and Armbian).

    If you install OMV using one of these -> guides, following the guidance provided, the install should work fine as it has for thousands of users.

    If you're doing your own install, picking a Debian distro of your choice and adding packages before running the script, that's not supported.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!