Another missing RAID

  • Had a power outage, when turning back on the raid was missing..


    Ran through the post suggested, managed to get back 4 of the 5 disks


    mdadm --stop /dev/md0

    mdadm --assemble --force --verbose /dev/md0 /dev/sd[abce]


    root@OMVStore:~# mdadm --detail --scan --verbose

    ARRAY /dev/md0 level=raid5 num-devices=5 metadata=1.2 name=OMVStore.local:Pool UUID=2e78b60b:c6be877d:728ea7fd:ce696755

    devices=/dev/sdb,/dev/sdc,/dev/sdd,/dev/sdf



    root@OMVStore:~# cat /proc/mdstat

    Personalities : [raid6] [raid5] [raid4] [linear] [multipath] [raid0] [raid1] [raid10]

    md0 : active raid5 sdb[1] sdc[2] sdd[3] sdf[4]

    11720536064 blocks super 1.2 level 5, 512k chunk, algorithm 2 [5/4] [_UUUU]

    bitmap: 13/22 pages [52KB], 65536KB chunk


    unused devices: <none>


    RAID is back in the GUI however in degraded state, probably due to the missing drive /dev/sda drive, its there and SMART says all good.
    tried the recover option and picking the drive, this yields a error message.


    Also tried this from another post similar where it was missing a drive
    mdadm --readwrite /dev/md0

    this gives


    mdadm: failed to set writable for /dev/md0: Device or resource busy


    Any suggestions to get that drive attached and remove the degraded state of the RAID?

    Cheers

  • darthbob

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!