RPi4B - Mounted USB but not showing under Samba Shares as shareable

  • I plugged in the ext4 USB drive on the Raspberry Pi 4B

    The device showed up as /dev/sba drive and /dev/sba1 as a small swap (unused) and /dev/sba2 as my large partition of the files I wish to share on the server.


    I created a mount directory with permissions:

    sudo mkdir -p /mnt/sda2
    sudo chown -R pi:pi /mnt/sda2


    I added a mount to the /etc/fstab file and rebooted after adding this:

    UUID=xxxxxx(of my drive) /mnt/sda2 ext4 defaults,auto,users,rw,nofail,noatime 0 0


    The contents of the USB drive appear under the /mnt/sda2 when I view it via RPi terminal.

    Checking with OMV "File Systems", there is a YES under the mount /dev/sda2 (no reference to what I have it mounted which is /mnt/sda2 )


    Now after enabling Samba on OMV, when I go to the SMB menu and click the option to ADD

    There are no select-able items that appear when I select Services, SMB/CIFS, Shares, Add and click the down arrow in the "Device" field.


    If I click on the "Device" field, the window just flashes and if I attempt to type in the line /mnt/sda2/Videos that exists on the share, it blanks it out as well.


    How to I share the drive I just mounted at /mnt/sda2 ?


    I want to create several shared including /mnt/sda2/Videos, /mnt/sda2/Sketches, /mnt/sda2/Dissertations, etc. (not these directories are already created on the USB drive and are full of files now.

    Thanks!

  • I found my answer here: Unable to select mounted device from dropdown after following more searches by changing my question around.


    I removed the mount line I had added from FSTAB, rebooted and used the option Storage, File Systems and when the line /dev/sda2 now showed NO under the mounted tab. I clicked on the line to highlight and then clicked MOUNT and the drive mounted. I was then able to go and define the already existing sub-directories off that mount in the Access Management, Shared folders list Once I added each share, I was able to enter the Services, SMB/CIFS, Shares and at that time, all of the share names were selectabl in the drop down "shared folder" list.


    Otherwise ... quite the tough crowd here, I noticed. Master helpers calling users stupid "in general" in their signatures and a general new-user demeaning tone I've not seen in other arenas for "bridge software" such as this. I'd speak with the marketing group to see how, if any, this encourages new OMV users. Not being a Linux professional, I can't say this for certain but good chance that Linux professionals may actually use more traditional methods of file sharing and this nice OMV interface and where it actually shines would be more of a migration point of entry to the general masses who see the Linux-world as too daunting to attempt otherwise. OMV may actually be serving as an important educational gateway for the LInux beginner. Letting new people know how dumb they are, what paragraph they didn't pick up on in a perhaps (to them) infinite pool of seemingly unrelated reference material, well in my many years of IT experience this is not the best way to bring in new students into your group. When a group forms the strategy of standing behind the platform with a balloon to pop on the new user's first walk through the door, it doesn't exactly come through as a "welcome". Now granted your own experiences may vary in this area but these are mine .....


    To summarize: You catch more flies with honey than vinegar.

  • A good starting point to get into OMV is the guide section of this forums. Especially

    New User Guide - Getting Started with Openmediavault 4 & 5

    Solutions to common problems (Problem #2 is yours)


    and in general:

    https://openmediavault.readthedocs.io/en/latest/index.html

  • Otherwise ... quite the tough crowd here, I noticed. Master helpers calling users stupid "in general" in their signatures and a general new-user demeaning tone I've not seen in other arenas for "bridge software" such as this. I'd speak with the marketing group to see how, if any, this encourages new OMV users.

    Unfortunately, being a public forum, there's no effective way to stop or, in the short term, contain an abrasive user. The particular individual you're referring to is gone, BTW.

    I think you'll find the vast majority of forum contributors and users to be friendly. Some of us have gone to great lengths to create New User documents that are friendly, easy to understand, and informative.

  • I figured it out. I did all the sharing via OMV. Basically follow install a fresh image and then ...

    - Install OMV

    - All USB attached drives will appear in list under "File Systems"

    - Select each that will be shared by clicking the line for it and then use the MOUNT option

    - Once all mounted, save the changes

    - Now click "Shared Folders" and add a share for each directory selected from the USB drives you mounted before

    - Now click "SMB/CIFS" and use the "Shares" tab to add each Shared Folder you added before that you want to share over the network

    - Optionally create a symbolic link to shorten the long names like below if you will be working with the share on the console or via transmission.

    /srv/dev-disk-by-id-usb-ST5000DM_000-xxxxxx_xxxxxxxxxxxxxxxx-0-0-part2

    to /Med

    - Optionally now install transmission and follow links online to change ID "debian-transmission" ID to "pi" ID

    - shut down transmission and change transmission configuration file to point to SMB shares and change value "umask" from 18 to 2 if you want files that can be read by groups (775), then restart it

    - now you should be able to have your Windows user and transmission both capable of accessing the share.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!