Nextcloud on OMV5 - OMV GUI not accessible

  • Hallo zusammen,


    erst einmal vielen Dank für eure Unterstützung. Ich habe mir mehrere Forum Posts angeschaut, jedoch finde ich keinen, der mein Problem löst.

    Ich bin kein Netzwerk, noch linux experte, darum verzeiht mir Fehler, die in euren Augen dumm erscheinen.


    Was ist das Problem:

    - Ich kann die Web Gui von OMV nicht erreichen, nachdem ich Nextcloud installiert habe.


    relevante Informationen:

    - ich habe Nextcloud nach dieser Anleitung installiert (https://dbtechreviews.com/2020…th-remote-access-and-ssl/) auch wenn ich beim Punkt "SMB CLient Configuration Setup" nicht pecl sondern apt benutzt habe, um den smb client zu installieren.

    - Vor der Nextcloud installation konnte ich die GUI ohne Probleme über https://your-ip:81 erreichen

    - Nextcloud, ssh etc. funktioniert

    - omv-firstaid schon ausprobiert (Allgemeine Netzwerkeinstellungen + WebGui Port)



    Welche Infos kann ich noch beilegen, damit ihr mir einfacher helfen könnt?


    Vielen Dank im Voraus,

    B0ld07

  • KM0201

    Approved the thread.
  • Welche Infos kann ich noch beilegen, damit ihr mir einfacher helfen könnt?

    Was passiert denn beim Aufruf von "https://your-ip:81"? Kommt eine Fehlermeldung? Wird die Nextcloud angezeigt? Bekommst du einen Timeout? Bist du sicher, dass du httpS verwendet hast und nicht http? Ist die Nextcloud mit HSTS konfiguriert?

    Was sagt

    Code
    systemctl list-units --failed
    systemctl status nginx.service
    tail /var/log/nginx/error.log
  • Steini! DU bist ein Gott!


    Vielen Dank. Aufgrund der Kommandos habe ich den Fehler gefunden.

    Im Guide wird gesagt, dass man unter /etc/nginx/nginx.conf folgendes einfügen soll:

    Code
    server {
        client_max_body_size 0;
    }


    Echt vielen Dank! Saß schon mega lange dran und jetzt fixt du das sooo schnell.

    Danke Danke Danke

  • Hallo,


    nach einem Stromausfall hab' ich meinen OMV 5.5 server wieder am laufen. Nextcloud im docker (incl. letsencrypt etc) funktioniert ebenfalls.

    Allerdings funktioniert das OMV-GUI nicht mehr.


    Evtl. kann mir hier jemand weiterhelfen. Danke schonmal!


    In Bezug auf #2:
    Anscheinend ist es nicht nur der nginx, der ein Problem hat:

    Code
    root@serv01:~# systemctl list-units --failed
    UNIT LOAD ACTIVE SUB DESCRIPTION
    ? srv-7d53c928\x2d8f05\x2d4c12\x2dbff7\x2d4464804930ca.mount loaded failed failed /srv/7d53c928-8f05-4c12-bff7-4464804930ca
    ? nginx.service loaded failed failed A high performance web server and a reverse proxy server
    ? quotaon.service loaded failed failed Enable File System Quotas
    Code
    root@awz-serv01:~# tail /var/log/nginx/error.log
    2021/02/23 22:53:35 [emerg] 22085#22085: "server" directive is not allowed here in /etc/nginx/nginx.conf:67
    Zeile 67ff:
    server {
    client_max_body_size 0;
    }


    omv-firstaid hatte ich versucht, allerdings ohne Erfolg.


    Vielen Dank und LG - tullsta

  • Hello,


    just for other which might have a same issue:

    I commented out the lines 67...69 in /etc/nginx/nginx.conf:

    Code
    server {
    client_max_body_size 0;
    }

    and then things worked fine again (after rebooting).


    However, I do not understand the reason for this being necessary and why this happened at all.

    It would be nice if someone could help to understand this issue.


    Liebe Gruesse - tullsta

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!