Standby problem

  • Hello,


    I've installed the new OMV on my homemade NAS. Now I've the problem, that the HDD goes to standby and don't come back when I access them from my PC. There are no settings for PM in OMV set. Any idea what it can be?


    thank you!

  • As far as i know there should be no issue in OMV that should prevent your drives from starting up. Your error could be because the bios/controller on your mobo haven't implementet the power up from sleep commands in the disk protocol.


    Another issue could be if you have old hdparm settings stored on the disks - In a console try
    hdparm -I <drive> like:

    Code
    hdparm -I /dev/sda


    The last issue should be if your disks doesn't support power management.
    Hdparm -I should list all the drive parameters. The command parameters with a star is the ones that are implemented. So if you do not have a start in the row with "Power Management feature set" then you're disks isn't supporting power down

  • Thank you jensk!


    I have a star on "power managment feature set". So normaly the drive should not suspend or? Btw it's a external USB HDD. Perhaps this is my problem. Before I worked witg BSD an I had not this problem.

  • To my knowledge you can't power/spin down USB harrdrives that are mounted in linux. If you wan't to spin down a usb harddrive under linux you will have to unmount it first.
    Or
    you can use the sg3-utils package for this. It can do to external drives what hdparm cannot.


    Code
    apt-get install sg3-utils


    issue:

    Code
    sg3_start --pc=3 <disk_device_id>


    like

    Code
    sg3_start --pc=3 /dev/sdg


    The --pc=3 parameter sets the disk in standby mode which the system should be able to wake the disk from when accessing it.
    To get the system to set the disk ind standby mode on a regular basis you will have to put the command in a cron job with crontab -e

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!