Just for warning, i'm very much noob at this but i'm learning in small steps. 2 days ago I didn't even knew that OMV exists and what it does so... Also don't know much about linux.
I will explain some thing infront:
- using HP HP Compaq 6200 Pro Small Form Factor PC, Intel® Pentium® Dual-Core G620 (2.60 GHz, 3 MB cache, 2 cores), 6 GB 1333 MHz DDR3 SDRAM, 3xSATA disks..
- installed 5.9.0-0.bpo.2-amd64 #1 SMP Debian 5.9.6-1~bpo10+1 (2020-11-19) x86_64 GNU/Linux, with OMV 5.5.11-1 usul
- connection is made through Ethernet onto Windows machine which has mobile 4G internet connection and i shared that connection through Windows machine ethernet port. Both Linux and Windows machines are connected through gigabit switch and i can confirm that my shared folders works as i already established shared folders for 1 account. I can ping Windows machine, and Google so my internet settings should be ok.
Now, what is my idea... I would like to have Joomla Cms installed on server. Usually i have Xampp installed on Windows and thats the area i'm use to, but Linux is much different for me. So if i want Joomla on OMV i saw i need to install Omv-Extras but that didn't worked for me. After
wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash" command i got this:
"Preparing to unpack openmediavault-omvextrasorg_latest_all5.deb ...
Unpacking openmediavault-omvextrasorg (5.4.2) ...
dpkg: dependency problems prevent configuration of openmediavault-omvextrasorg:
openmediavault-omvextrasorg depends on dirmngr; however:
Package dirmngr is not installed."
So i need dirmnmgr and i went with
apt install curl wget apt-transport-https dirmngr
and i got an error:
"The following packages have unmet dependencies:
curl : Depends: libcurl4 (= 7.64.0-4+deb10u1) but it is not going to be installed
dirmngr : Depends: gpgconf (= 2.2.20-1~bpo10+1) but it is not going to be installed
Depends: libassuan0 (>= 2.5.0) but it is not installable
Depends: libksba8 (>= 1.3.4) but it is not installable
Depends: libnpth0 (>= 0.90) but it is not installable
E: Unable to correct problems, you have held broken packages."
Anyway i stuck. I probably made mistakes somewhere and I don't know where anymore