dmesg failed - error - watchdog: iTCO_wdt: cannot register miscdev on minor - disabling ASPM

  • Hello User,


    how can i solve this problem?


    Code
    [ 60.876676] iTCO_vendor_support: vendor-support=0
    [ 60.959914] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
    [ 60.959967] iTCO_wdt: Found a ICH8 or ICH8R TCO device (Version=2, TCOBASE=0x1060)
    [ 60.959989] watchdog: iTCO_wdt: cannot register miscdev on minor=130 (err=-16).
    [ 60.960067] watchdog: iTCO_wdt: a legacy watchdog module is probably present.
    [ 60.960182] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
    [ 61.084256] coretemp coretemp.0: Using relative temperature scale!

    Should i use this old solution?


    softdog error


    I have the problem this Kernel 4.19.0-13-amd64 and 5.9.0-0.bpo.2-amd64.


    My cpu




    Greets


    openmedianer



    Hardware: FSC Mainboard D2312 Year: 2006

  • My old problem:


    [solved] load the correct watchdog kernel module - using a fake install


    My solution, 2020:


    Code
    echo blacklist mei_me > /etc/modprobe.d/mei_me-blacklist.conf
    echo blacklist iTCO_wdt > /etc/modprobe.d/iTCO_wdt-blacklist.conf
    echo blacklist iTCO_vendor_support > /etc/modprobe.d/iTCO_vendor_support-blacklist.conf
    echo blacklist miscdev > /etc/modprobe.d/miscdev-blacklist.conf
  • New problem:


    Code
    dmesg | grep failed
    [ 0.544432] acpi PNP0A08:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
    [ 28.777178] platform regulatory.0: firmware: failed to load regulatory.db (-2)
    [ 28.777182] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
    [ 28.777186] cfg80211: failed to load regulatory.db

    https://askubuntu.com/question…d-ae-error-disabling-aspm


    Quote

    This error message occurs when the kernel runs the root PCI bridge _OSC control method in your firmware and the execution fails, perhaps due to a bug in the firmware or perhaps it does not exist. The kernel hence cannot determine the features supported or capabilities provided by the device (as specified by your firmware) and hence has to disable PCIe ASPM (Active State Power Management).


    https://www.reddit.com/r/linux…led_to_load_regulatorydb/



    https://lists.debian.org/debian-user/2015/02/msg00626.html

  • openmedianer

    Changed the title of the thread from “watchdog: iTCO_wdt: cannot register miscdev on minor=130 (err=-16).” to “dmesg failed - error - watchdog: iTCO_wdt: cannot register miscdev on minor - disabling ASPM”.
  • https://unix.stackexchange.com…daemon-for-bios-watch-dog


    Quote

    3. Un-comment watchdog-device = ...

    So actually use the /dev/watchdog device access to the module. Otherwise the watchdog will not use the hardware and rely only on its internal code to soft-reboot a broken machine (which is not so useful).

    Again, on starting the watchdog daemon look for messages in syslog about it starting and what hardware module it has found.



    Code
    cat /etc/watchdog.conf
    # This file is auto-generated by openmediavault (https://www.openmediavault.org)
    # WARNING: Do not edit this file, your changes will get lost.
    #watchdog-device = /dev/watchdog
    # This greatly decreases the chance that watchdog won't be scheduled before
    # your machine is really loaded
    realtime = yes
    priority = 1
  • Code
    echo blacklist mei_me > /etc/modprobe.d/mei_me-blacklist.conf
    echo blacklist iTCO_wdt > /etc/modprobe.d/iTCO_wdt-blacklist.conf
    echo blacklist iTCO_vendor_support > /etc/modprobe.d/iTCO_vendor_support-blacklist.conf
    echo blacklist miscdev > /etc/modprobe.d/miscdev-blacklist.conf

    You can use one blacklist, e.g. /etc/modprobe.d/watchdog-blacklist.conf to list the watchdog modules you don't want to load. No need for that clutter. But why do you disable the Intel management interface engine (mei_me) and the Intel watchdog device (iTCO_wdt)? I think the latter is the better choice then softdog (which you probably loaded). The error you describe is thrown because there is already a watchdog module (probably softdog) loaded when iTCO_wdt tries to register. miscdev is not a module at all and cannot be blacklisted.


    The regulatory.db file is provided by the wireless-regdb package. You probably want to read /usr/share/doc/wireless-regdb/README.Debian about how to enable it for your kernel.


    The ASPM error can be ignored if you don't experience any issues. Otherwise you'll have to dig deep. Are you sure you have all the necessary firmware installed (linux-firmware-nonfree)?

    Edited once, last by dleidert: add missing slash to file path ().

  • Hello dleidert, thank you for your input.


    I'm sure to have install linux-firmware-nonfree.

    My files in /etc/modprobe.d

    Code
    /etc/modprobe.d# tree
    .
    ├── iTCO_vendor_support-blacklist.conf
    ├── iTCO_wdt-blacklist.conf
    ├── mdadm.conf
    ├── mei_me-blacklist.conf
    ├── miscdev-blacklist.conf
    └── openmediavault.conf
    0 directories, 6 files


    My cleaned files in /etc/modprobe.d (omv 5, default)

    Code
    /etc/modprobe.d# tree
    .
    ├── mdadm.conf
    └── openmediavault.conf

    I'm reboot my system.


    dmesg


    https://nopaste.linux-dev.org/?1326444


    My dmesg problems


    How should i create my /etc/modprobe.d/watchdog-blacklist.conf to solved my problems?


    My new watchdog-blacklist.conf


    Code
    cat /etc/modprobe.d/watchdog-blacklist.conf
    blacklist iTCO_wdt


    Code
    tree
    .
    ├── mdadm.conf
    ├── openmediavault.conf
    └── watchdog-blacklist.conf
    0 directories, 3 files


    How can i solve the two follows problems?




    Code
    cat usr/share/doc/wireless-regdb/README.Debian
    cat: usr/share/doc/wireless-regdb/README.Debian: No such file or directory


    I don't have any idea.


    Thank you


    openmedianer

  • My Kernel 5.9.0-0.bpo.2-amd64




    Reboot


    Code
    uname -r
    4.19.0-13-amd64


    dmesg, only one problem


    Code
    [ 75.037276] IPv6: ADDRCONF(NETDEV_CHANGE): wlx204e7fd892cd: link becomes ready
    [ 196.913648] watchdog: Software Watchdog: cannot register miscdev on minor=130 (err=-16).
    [ 196.913713] watchdog: Software Watchdog: a legacy watchdog module is probably present.
    [ 196.913817] softdog: initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout=0)

    How can i solve this problem?



    I will read my old solution: RE: [solved] load the correct watchdog kernel module - using a fake install

  • The solution for my problems:


    The same as Jan 2019: RE: [solved] load the correct watchdog kernel module - using a fake install


    Code
    rm /etc/modprobe.d/watchdog-blacklist.conf

    For my system i don't need to "blacklist iTCO_wdt"


    Code
    /etc/modprobe.d# tree
    .
    ├── iTCO_wdt.conf
    ├── mdadm.conf
    ├── openmediavault.conf
    └── softdog.conf



    Code
    cat iTCO_wdt.conf
    install iTCO_wdt /bin/true



    Code
    cat softdog.conf
    install softdog /bin/true

    My used kernel


    Code
    uname -r
    4.19.0-13-amd64


    The dmesg output i now without red messages, clean an nic.

    The bootime is much better.

  • @ryecoaaron


    Hello, i have install my system with your nice script.


    RE: [solved] Update problem - Failed to execute command 'export PATH=/bin:/sbin.....................................................


    Why do you use the Kernel 5.9.0-0.bpo.2-amd64 ?


    In my case i have many trouble.


    Whe i have every time trouble with the bpo Kernel Jan. 2019 (4.18.0-0.bpo.3-amd64)

    and Dec. 2020 (5.9.0-0.bpo.2-amd64)?


    Greets


    openmedianer

  • The softdog module is a pure software watchdog driver and is supposed to be a fallback if no hardware driver can be found, while iTCO_wdt is the driver to use the Intel hardware watchdog. So you probably want to blacklist softdog among these two modules.


    Check out sudo modinfo softdog and sudo modinfo iTCO_wdt (modinfo shows you the details about a given module).

    Edited 2 times, last by dleidert: add hint about modinfo ().

  • My used kernel


    Code
    uname -r
    4.19.0-13-amd64

    I pointed you to the README.Debian of the wireless-regdb package. Unfortunately I missed the leading slash in the path (and you obviously havn't figured this out by yourself). In this file it is clearly stated that regulatory.db is only autoloaded by kernel 5.5 and upwards. So for a 4.x kernel you'll need the crda package which contains the scripts to load it.


    May I point out that you have no idea what you are doing, that you are changing system settings via trial-and-error, and that you can horribly misconfigure your system by continuing to do so?

  • modinfo softdog


    modinfo iTCO_wdt




    Code
    cat /usr/share/doc/wireless-regdb/README.Debian
    cat: /usr/share/doc/wireless-regdb/README.Debian: No such file or directory


    I don't can find the README.Debian.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!