Sudden Drop in Speed

  • Hi,


    I've been running OMV (5.5.19-1) for a while. Until a few days ago I was getting around 80MBps (average) transfer speeds on my desktop. All of a sudden (I've not changed anything save doing to the usual apt update && apt full-upgrade) I'm now only seeing 10MBps max transfer speeds and I can't work out what's caused the sudden slow down. I rebooted OMV, the desktop, the network switch and the router and nothing's changed.


    I've ran fstrim / with no luck and I've tried on other devices to see if its just my desktop and I'm actually seeing even worse performance over wifi at about 600kbps to my phone which previously was getting between 40-60MBps over wifi.


    I've got the below options configured in the extra options section for samba


    In the extra options on the samba settings page:

    Code
    socket options = TCP_NODELAY IPTOS_LOWDELAY
    min receivefile size = 16384
    use sendfile = yes
    write cache size = 524288
    getwd cache = yes

    In the extra options for each samba share:

    Code
    log level = 1
    socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    read raw = yes
    write raw = yes
    max xmit = 65535
    dead time = 15
    getwd cache = yes


    I've tried removing all these settings but it actually gets worse dropping to about 3MBps!


    Below are the results from iperf3 which seems to be getting the speeds I'm expecting between the computer and the NAS but I'm just not seeing the speeds in samba.



    OMV is running on an ODroid XU4 with 2 WD 10tb drives attached (https://www.amazon.co.uk/gp/pr…_asin_title?ie=UTF8&psc=1)


    Any help getting back to the original speeds would be much appreciated!!

  • KM0201

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!