Upgrade Scripts for non-interactive major release upgrades (2->3, 3->4, 4->5)

  • bart70 the issue seems related to the storage device mentioned below.

    my guess: because fuse filesystem driver is used, it seems to be a device using a Windows filesystem (i.e. USB disc or SD card)
    that should be removed


    affected storage device:

    Re-mounting /srv/61395eeb-7f47-498c-acef-91e88741b6bc read-only

    fuse: mountpoint is not empty

    omv 6.0.31-2 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • thanks !
    how can i stop this driver during the update ? i don't find it in the documentation, thanks

  • unplug it before you start the computer

    omv 6.0.31-2 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Hi everyone, I used the script to upgrade from omv4 to 5.


    All passed well until "81-apt-dist-upgrade-omv" where i got theses errors :


    PHP Fatal error: Uncaught Error: Call to undefined function mb_strtolower() in /usr/share/php/openmediavault/autoloader.inc:28

    Stack trace:

    #0 [internal function]: {closure}('OMV\\Engine\\Modu...')

    #1 Standard input code(2): spl_autoload_call('OMV\\Engine\\Modu...')

    #2 {main}

    thrown in /usr/share/php/openmediavault/autoloader.inc on line 28

    dpkg: error processing package openmediavault (--configure):

    installed openmediavault package post-installation script subprocess returned error exit status 255

    [...]

    Errors were encountered while processing:

    openmediavault

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    [...]

    Processing system modifications ...

    PHP Fatal error: Uncaught Error: Call to undefined function mb_strtolower() in /usr/share/php/openmediavault/autoloader.inc:28

    Stack trace:

    #0 [internal function]: {closure}('OMV\\Engine\\Modu...')

    #1 Standard input code(2): spl_autoload_call('OMV\\Engine\\Modu...')

    #2 {main}

    thrown in /usr/share/php/openmediavault/autoloader.inc on line 28

    dpkg: error processing package openmediavault (--configure):

    installed openmediavault package post-installation script subprocess returned error exit status 255

    Errors were encountered while processing:

    openmediavault

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    run-parts: /root/upgrade-omv4to5/openmediavault-upgrade-4.7/run.d/81-apt-dist-upgrade-omv exited with return code 100



    For informations I have also Plex and Nextcloud installations on this VM (installed manually and not by omv plugins).

    When I have updated to Nextcloud 20 I migrated to php 7.4 and I have also make change about omv to use this same version.


    For the moment after a reboot, Plex and Nextcloud work well. But OMV doesn't work (admin interface where I can't login and get Internal Server Error). The /var/log/syslog where I have these errors many time :


    Oct 29 14:50:37 omv monit[941]: 'php-fpm' process is not running

    Oct 29 14:50:37 omv monit[941]: 'php-fpm' trying to restart

    Oct 29 14:50:37 omv monit[941]: 'php-fpm' start: '/bin/systemctl start php7.3-fpm'

    Oct 29 14:51:07 omv monit[941]: 'php-fpm' failed to start (exit status 5) -- '/bin/systemctl start php7.3-fpm': Failed to start php7.3-fpm.service: Unit php7.3-fpm.service not found.#012

    Oct 29 14:51:07 omv monit[941]: 'nginx' failed protocol test [HTTP] at [127.0.0.1]:443 [TCP/IP] -- HTTP error: Server returned status 400

    Oct 29 14:51:07 omv monit[941]: 'nginx' trying to restart

    Oct 29 14:51:07 omv monit[941]: 'nginx' stop: '/bin/systemctl stop nginx'

    Oct 29 14:51:07 omv systemd[1]: Stopping nginx - high performance web server...

    Oct 29 14:51:07 omv systemd[1]: nginx.service: Succeeded.

    Oct 29 14:51:07 omv systemd[1]: Stopped nginx - high performance web server.

    Oct 29 14:51:07 omv monit[941]: 'nginx' start: '/bin/systemctl start nginx'

    Oct 29 14:51:07 omv systemd[1]: Starting nginx - high performance web server...

    Oct 29 14:51:07 omv systemd[1]: Started nginx - high performance web server.

    Oct 29 14:51:07 omv monit[941]: 'omv-engined' process is not running

    Oct 29 14:51:07 omv monit[941]: 'omv-engined' trying to restart

    Oct 29 14:51:07 omv monit[941]: 'omv-engined' start: '/bin/systemctl start openmediavault-engined'

    Oct 29 14:51:07 omv systemd[1]: Starting The OpenMediaVault engine daemon that processes the RPC request...

    Oct 29 14:51:07 omv omv-engined[16457]: PHP Fatal error: Uncaught Error: Call to undefined function mb_strtolower() in /usr/share/php/openmediavault/autoloader.inc:28

    Oct 29 14:51:07 omv omv-engined[16457]: Stack trace:

    Oct 29 14:51:07 omv systemd[1]: openmediavault-engined.service: Supervising process 16457 which is not our child. We'll most likely not notice when it exits.

    Oct 29 14:51:07 omv omv-engined[16457]: #0 [internal function]: {closure}('OMV\\Environment')

    Oct 29 14:51:07 omv systemd[1]: Started The OpenMediaVault engine daemon that processes the RPC request.

    Oct 29 14:51:07 omv omv-engined[16457]: #1 /usr/sbin/omv-engined(357): spl_autoload_call('OMV\\Environment')

    Oct 29 14:51:07 omv omv-engined[16457]: #2 {main}

    Oct 29 14:51:07 omv omv-engined[16457]: thrown in /usr/share/php/openmediavault/autoloader.inc on line 28

    Oct 29 14:51:07 omv systemd[1]: openmediavault-engined.service: Main process exited, code=exited, status=255/EXCEPTION

    Oct 29 14:51:07 omv systemd[1]: openmediavault-engined.service: Failed with result 'exit-code'.

    Oct 29 14:51:37 omv monit[941]: 'omv-engined' failed to start (exit status 0) -- no output



    Do you have an idea ? I attached the full log upgrade.

  • Oct 29 14:50:37 omv monit[941]: 'php-fpm' process is not running

    Oct 29 14:50:37 omv monit[941]: 'php-fpm' trying to restart

    Oct 29 14:50:37 omv monit[941]: 'php-fpm' start: '/bin/systemctl start php7.3-fpm'

    Oct 29 14:51:07 omv monit[941]: 'php-fpm' failed to start (exit status 5) -- '/bin/systemctl start php7.3-fpm': Failed to start php7.3-fpm.service: Unit php7.3-fpm.service not found.#012

    AFAIK, OMV5 needs php7.3 and when you installed/updated to php7.4, you make it FUBAR

    RE: OMV5 & Nextcloud PHP versions

    For informations I have also Plex and Nextcloud installations on this VM (installed manually and not by omv plugins).

    When I have updated to Nextcloud 20 I migrated to php 7.4

  • Ok so no way to configure omv5 to use php7.4 like I did with omv4 ?

    Don't really know the answer to that one.


    Maybe ryecoaaron (sorry to poke you, ;) )can give you a better answer.

  • no way to configure omv5 to use php7.4

    correct. This was Volker's answer on a similar question I raised on github.

    To run OMV and NextCloud on the same computer use a docker container for NextCloud or a virtual machine

    omv 6.0.31-2 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.15.32-v8+

    2x 6TB 3.5'' HDDs (CMR) formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with 32bit Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs (CMR) formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Ok so no way to configure omv5 to use php7.4 like I did with omv4 ?

    Unless you hacked omv files, you weren't using php 7.4 for omv4. If you need php 7.4, run it in a container.

    omv 6.0.33-1 Shaitan | 64 bit | 5.15 proxmox kernel | plugins :: omvextrasorg 6.1.1 | kvm 6.1.22 | mergerfs 6.1.1 | zfs 6.0.11
    omv-extras.org plugins source code and issue tracker - github


    Please try ctrl-shift-R and read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Just wanted to say: Thank you


    It worked like a charm after manually removing mywebsql

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • thanks, but i think i don't have any device like that ... how can i find it or find some infos on it

    Maybe you can just have a look inside with


    ls /srv/61395eeb-7f47-498c-acef-91e88741b6bc


    or have a look what is mounted at the point with


    mount 


    Did you stop all services as mentioned in the docs?

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • yes, i've (tried) to stop all services ;)

    i did the ls /srv/61395eeb-7f47-498c-acef-91e88741b6bc

    it's my mergeFS ... i don't know how i can stop it during the update :(

  • Never used mergerFS, so can't help.

    If mergerFS wors as I understand you can just remove the union file system, do the update and re-create it.


    Have a backup ready.


    Maybe someone else can help out from here.

    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

  • thanks, before remove the union file system, i'll wait another advice about it ... i got a copy of my datas on another NAS , but i'd like to avoid a recopy of them ...

  • Hi everybody,


    today I wanted to upgrade from 4.16 to 5.x using this script, deactivated all the services except SSH, uninstalled the plugins and let the script run, but at the end I get the following errors:

    Tried to remove these packages (nginx-X, openmediavault) a couple of times, on every new attempt to install openmediavault I get the same error. Where should I start to find the error?


    Thanky for your help!!!

  • Id don't know what you did to remove openmediavault, but the nginx startup fails, because it tries to include the file /etc/nginx/sites-enabled/openmediavault-nginx which it can not read.


    What is the result of

    ls -la /etc/nginx/sites-enabled and

    ls -la /etc/nginx/sites-available?


    If you got help in the forum and want to give something back to the project click here (omv) or here (scroll down) (plugins) and write up your solution for others.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!