Internal Error during 5.5.20-1 update; no more web access after.

  • Today i've updated 2 OMV's installations.


    During the process the same error occur: =Internal server error=


    After the update, the web page is unreacheable with the error 500 on http.


    Reboot doesnt resolve anything.


    All services works; SMB, FTP, Docker.


    Any suggest?

  • Strange, I just updated about 45min ago and all is well here (just did a reboot to double check).


    Anything interesting in /var/log/syslog

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • /var/log/syslog

  • Nevermind, use google, you'll find a possible solution.

    .

    root@openmediavault:~# cat /var/log/nginx/error.log

    2020/12/30 10:46:27 [alert] 18479#18479: *1 open socket #18 left in connection 2

    2020/12/30 10:46:27 [alert] 18479#18479: aborting

    2020/12/30 10:47:33 [alert] 30656#30656: *3 open socket #19 left in connection 3

    2020/12/30 10:47:33 [alert] 30656#30656: aborting

    2020/12/30 10:48:39 [alert] 2687#2687: *2 open socket #18 left in connection 2

    2020/12/30 10:48:39 [alert] 2687#2687: aborting

    2020/12/30 10:59:23 [alert] 24719#24719: *2 open socket #18 left in connection 2

    2020/12/30 10:59:23 [alert] 24719#24719: aborting

    2020/12/30 11:02:00 [alert] 4173#4173: *3 open socket #19 left in connection 3

    2020/12/30 11:02:00 [alert] 4173#4173: aborting

    2020/12/30 11:15:01 [alert] 7946#7946: *2 open socket #19 left in connection 3

    2020/12/30 11:15:01 [alert] 7946#7946: aborting

    2020/12/30 11:17:56 [alert] 567#567: *4 open socket #19 left in connection 3

    2020/12/30 11:17:56 [alert] 567#567: aborting

  • Should be only 7.3

    so what to do?


  • I would guess it is an incomplete upgrade to OMV 5.x from 4.x. What is the output of: dpkg -l | grep openm


    If the status of the openmediavault package is 'ii' then I would

    omv-salt deploy run nginx phpfpm

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Just checking in... I had the exact same issue and exact same error, removing the leftover php7.0 packages (weren't depended on by anything) then re-running the salt deploy for nginx and phpfpm fixed it for me too. Thank you!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!