"Server does not support non-ASCII-symbols" - how to enable UTF8 serverwide?

  • Good morning everyone,


    I just set up OMV on a spare PC with an i3 3. Gen, 16 GB RAM and 3 HDD in a mirror raid with 3 TB storage. The system ist installed on a SATA SSD and everything works well.

    My issue is that when I connect with FileZilla, I always get the message that the server does not support ASCII symbols. This causes issues when there are files with foreign symbols, it seems the server refuses to write them completely.


    I checked the DOC to see wether there are flags that need to be put into the field "additional options" in the FTP settings panel of omv but there is no info about that. I tried

    Code
    UseUTF8
    Code
    --nls-enable

    Both didn't work as OMV raised an error when saving. So I guess those are not valid (I don't even know where those parameters are passed too though).


    Basically my question is how do I enable UTF8 on OMV? The current debian locale is German UTF8.


    Edit: I tried lot's of other things, like modifying the mod_lang and mod_core module - via OMV web panel and directly inside the config. Weirldy enough nothing changes really. Whenever I connect it's stuck at "Connection established, waiting for welcome message" for a few seconds, then it connects to the server with the ascii warning message without displaying the weclome message. The weird thing is I could upload files with UTF8 characters but I can't delete folders with UTF8 specific letters because it can't list them. I didn't modify anything during the installation process. Please help :(


    Edit2: I noticed the proftdp config doesn't append the contents written into additional options in the web panel. Do I misunderstand something?

    Edited 3 times, last by anphex: Tried more things. More. ().

  • just set up OMV on a spare PC

    please tell us the OS version uname -aand OMV version dpkg -l | grep openmediavault

    omv 5.5.23-1 (usul) on RPi4 with Kernel 5.10.x and WittyPi 3 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!