"Server does not support non-ASCII-symbols" - how to enable UTF8 serverwide?

  • Good morning everyone,


    I just set up OMV on a spare PC with an i3 3. Gen, 16 GB RAM and 3 HDD in a mirror raid with 3 TB storage. The system ist installed on a SATA SSD and everything works well.

    My issue is that when I connect with FileZilla, I always get the message that the server does not support ASCII symbols. This causes issues when there are files with foreign symbols, it seems the server refuses to write them completely.


    I checked the DOC to see wether there are flags that need to be put into the field "additional options" in the FTP settings panel of omv but there is no info about that. I tried

    Code
    UseUTF8
    Code
    --nls-enable

    Both didn't work as OMV raised an error when saving. So I guess those are not valid (I don't even know where those parameters are passed too though).


    Basically my question is how do I enable UTF8 on OMV? The current debian locale is German UTF8.


    Edit: I tried lot's of other things, like modifying the mod_lang and mod_core module - via OMV web panel and directly inside the config. Weirldy enough nothing changes really. Whenever I connect it's stuck at "Connection established, waiting for welcome message" for a few seconds, then it connects to the server with the ascii warning message without displaying the weclome message. The weird thing is I could upload files with UTF8 characters but I can't delete folders with UTF8 specific letters because it can't list them. I didn't modify anything during the installation process. Please help :(


    Edit2: I noticed the proftdp config doesn't append the contents written into additional options in the web panel. Do I misunderstand something?

    Edited 3 times, last by anphex: Tried more things. More. ().

  • just set up OMV on a spare PC

    please tell us the OS version uname -aand OMV version dpkg -l | grep openmediavault

    omv 6.0.8 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.10.63

    2x 6TB 3.5'' HDDs formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Hi.

    I have the same problem!

    Running OMV on RPi 4B+


    OS version: Linux 5.10.17-v7l+ #1403

    OMV version:

    ii openmediavault 5.6.1-1 all openmediavault - The open network attached storage solution

    ii openmediavault-flashmemory 5.0.8 all folder2ram plugin for OpenMediaVault

    ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive

    ii openmediavault-omvextrasorg 5.6.2 all OMV-Extras.org Package Repositories for OpenMediaVault


    Problem is when my friend sends files via FTP with special characters like ,å ä ö...

    Used raspi-config to add sv-ISO8859-1 , sv-UTF-8, uk-UTF8.


    Please help!

  • I'd first update OS and OMV to up-to-date versions, then try again if the issue still exists

    omv 6.0.8 (Shaitan) on RPi CM4/4GB with 64bit Kernel 5.10.63

    2x 6TB 3.5'' HDDs formatted with ext4 via 2port PCIe SATA card with ASM1061R chipset providing hardware supported RAID1


    omv 5.6.21-1 (usul) on RPi4/4GB with Kernel 5.10.63 and WittyPi 3 V2 RTC HAT

    2x 3TB 3.5'' HDDs formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!