Very low transfer rate that increases after a transfer pause

  • Hello everyone,

    Two days ago I set up my own NAS thanks to openmediavault. With the help of various tutorials and my knowledge I deployed my NAS without any problems.

    However, once everything was set up, when it came time to transfer my files, I realized that my transfer rate is really low (10-11 Mbps). I noticed that when I pause the transfer and then restart it for a few seconds my transfer rate is around 90-125 Mbps for 3 to 10 seconds depending on the files. ( see attachements, the peak occurred when I stopped / restarted the transfer )

    Here are the specifics of my installation:

    - Modem and others -

    Thomson TG787 3x100Mps ports

    2 Category 7 cables ( Nas + my computer )

    - NAS -

    Motherboard: ASRock B550M-ITX/AC

    Hard disk: OS KINGSTON SKC2000M8250G

    DATA: 3x ST4000VN008-2DR166 4TO ( ext 4 )

    Ethernet network

    Before posting on the forum, I inquired on the internet and followed various solutions :

    - Tried a transfer from another gaming laptop ( with a SSD ), in ethernet and wifi for both of them.

    - Tried to uncheck the SMB1.0/CIFS in windows fonctionality

    - Tried the various solutions of the topics Tunning samba for more speed 1&2.

    - Made all check about update on NAS and Windows side

    - I looked at the common problems too :

    • Slow router/switch > The ports of my router have in 100Mb/s
    • No switch. > i have no switch
    • Slow USB interface. > I don't use USB
    • WiFi is used. > im in ethernet ( router and PC )
    • NTFS is used on the NAS. > im in ext4
    • Slow and feeble Windows client. > My computer is powerful, I tried the transfer on my SSD.
    • Bad cables. > New Cat 7 cables
    • Network extensions using power lines. > I am in LAN
    • Bad network configuration. > I don't think so, my architecture is simple, NAS and pc connected on my router, nothing more.
    • Slow drives > The hard drives I bought are made for NAS
    • Slow network interface. > How can I check this?
    • Small NAS overloaded with multiple tasks/transfers. > During a transfer, my CPU load is 0.8%, and my RAM load is 2.7%.

    Finally, here is a speed test that i did with iperf :

    Could you help me / Do you think to know where the problem comes from ?

    Thank you for reading me :)

  • Yeah it's 100Mbit/sec

    That's my router's hardware specifications


    • RJ11 DSL line port

    • Optional ISDN (Annex B)

    • Full FXO


    • 4-port autosensing 10/100Base-T auto-MDI/MDI-X Ethernet switch

    • 2 FXS POTS interfaces

    • 2 USB 2.0 masters

    • Wi-Fi IEEE 802.11b/g on board

    • Mini PCI 11n TELCO (802.11b/g/n)Possible HW extension

    • Integrated filt

  • So 11,4 MByte/sec is nearly the fastest speed you can have.

    So you have to update your hardware especially your LAN hardware.

    I bought the TP-Link - TL-SG105 but it did not change anything. Any idea ?

  • Are the ethernet cables connected like show below when you measure performance?

    NAS -> new TP switch

    PC -> new TP switch

    new TP switch -> router

    omv 5.6.5-1 (usul) on RPi4/4GB with Kernel 5.10.x and WittyPi 3 V2 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Yes; exactly like that

    Edit: i just found those two line on OMv syslog

    an 22 18:21:44 PhoeNas kernel: [ 176.646956] Generic FE-GE Realtek PHY r8169-400:00: Downshift occurred from negotiated speed 1Gbps to actual speed 100Mbps, check cabling!
    Jan 22 18:21:44 PhoeNas kernel: [ 176.646965] r8169 0000:04:00.0 enp4s0: Link is Up - 100Mbps/Full (downshifted) - flow control rx/tx

    The thing is strange is that i bought those 2 cables at the same time, and on windows side my ethernet card show 1Gbits/s

  • Delirious

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!