MotionEye - Outside access with SSL

  • Morlan also so forgot to mention, Macom advised to use the subfolder as that what was used for the Nextcloud not sure if that will help?


    Just looking through Macom instructions for setting up nextcloud and he has this section in there


    Could this be what im missing?

  • Morlan Ive got to work kind of....for somereason my browser says its dangerous????? but i go to the webpage on my mobile phone using mobile data it says its secure, tried it on another mobile phone and it also came up as secure.

  • Morlan and macom Thank you both, So i attempted what i wanted with Qbittorrent instead


    Moved to nextcloud network

    Edited "docker-compose.yml" subdomain to include qbitorrent

    changed qbittorrent.subfolder.conf.sample to qbittorrent.subfolder.conf

    Restarted Swag container

    Then went to *******.duckdns.org/qbittorrent

    Everything worked i could access it

    Which got me thinking if the following would work


    Edit qbittorrent.subfolder.conf.sample changed every mention of qbitorrent to motioneye and changed all 8080 port referances to 8765

    Saved the file as motioneye.subfolder.conf

    restarted Swag

    went to *******.duckdns.org/motioneye

    and haza!! everything worked, probaly should have wrote a guide on this im sure someone else will want the same thing everntually.




    But thank you so much!!!

  • STUKguy

    Added the Label resolved
  • Regarding update of the linuxserver/nextloud container there is a note on https://hub.docker.com/r/linuxserver/nextcloud


    Quote

    If you are not customizing our default nginx configuration you will need to remove the file:

    Code
    /config/nginx/site-confs/default

    Then restart the container to replace it with the latest one.

    Maybe it applies to your case as well.

  • macom Thank you again soo much,


    I installed the plug in "locate" on omv-extra, then searched for "site-confs" which gave me 4 results. 2 in the SWAG folder and 2 in the nextcloud folder.


    Used SSH to get to the location showen in the search result for SWAG typed in "rm -rf defaults" which deleted the folder then typed in "docker restart swag" went to my motion outside page and haza everything worked.


    Even though everything is working again i get this error

    **** The following nginx confs have different version dates than the defaults that are shipped. ****,

    **** This may be due to user customization or an update to the defaults. ****,

    **** To update them to the latest defaults shipped within the image, delete these files and restart the container. ****,

    **** If they are user customized, check the date version at the top and compare to the upstream changelog via the link. ****,

    /config/nginx/nginx.conf,


    Should i remove this too?

  • DISCLAIMER: This works if you already have other apps running on subdomain (nextcloud,plex,etc). and you have "SUBDOMAIN=wildcard" or "SUBDOMAIN=motioneye" added on you duckdns auth. (Maybe with other providers works also, I use duckdns)

    If you have your setting working with subfolders, this is not the right file.


    Thank you all for this. I have motioneye running since ever as a single stack but now is time to move it to SWAG, :D

    After reading through, I've done a small "motioneye.subdomain.conf.sample" to add to SWAG "nginx/proxy-confs"


    BIG Thank you to Morlan and macom for their tips:


    And the docker-compose.yml for motioneye that I previously had (just added it to the one with SWAG):

    NOTE: This is for Raspberry Pi running arm32 OS

    Hope this helps anyone.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!