Map drives Krusader in docker

  • Hi guys, I recently moved to OMV 5 and trying to instal Krusader in a docker.

    Sorry, I'm not a linux expert but it was working with the previous version and I can get this done here.


    After several trial and error from some web sources I managed to create the stack below:


    ---

    version: "2.2"

    services:

    krusader:

    image: binhex/arch-krusader

    container_name: krusader

    privileged: true

    environment:

    - PUID=0

    - PGID=0

    - UMASK_SET=000

    - TEMP_FOLDER=/config/krusader/tmp

    volumes:

    - /srv/dev-disk-by-uuid-4364ec4b-587f-4969-a93b-07c5c9f4baaa/AppData/Krusader:/config

    - /etc/localtime:/etc/localtime:ro

    ports:

    - 5900:5900

    - 6080:6080

    restart: unless-stopped


    I can get Krusader working, but I'm unable to map/mount all the filesystems (7) from my NAS.


    I suppose I need to add 7 extra lines like " - /srv/dev/sd1 ", " - /srv/dev/se1 " etc... but with no results



    Thanks for any help.

    Best, MAX

  • Really the same way you map any share... in macom's example, you just look in Krusader's file system, find data1, and there's your file system. You can just about any directory to a container... you're not constrained by what the author has set by default.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Thank you very much guys.

    I’m probably doing something wrong and I can’t debug due to my very basic knowledge.

    I can see the folder I try to mount but with no content inside. Can it be because the path may not be right?

    Best

    Max

  • Thank you very much guys.

    I’m probably doing something wrong and I can’t debug due to my very basic knowledge.

    I can see the folder I try to mount but with no content inside. Can it be because the path may not be right?

    Best

    Max

    That's what it sounds like.


    Did you set this up in Portainer? Take a screenshot of the volumes section of portainer.


    Edit: Nevermind, I see your compose file.. what did you add for your shared directories?

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Got it working, I was not using the right path of the filesystem!


    In case it happen to anyone else I'm now using the mount point that you can find in the file system page (you need to enable it as it is not visible as default)


    Thank you guys!!


    Best

    MAX

  • massimi72

    Added the Label resolved
  • are you taking about the /sharedfolders ? IF so, you'll have problems using that path in docker.. that's actually one of the reasons it was disabled by default

    Air Conditioners are a lot like PC's... They work great until you open Windows.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!