r-sync error for renaming aquota.group and others.

  • Hello all,


    After spending many hours with the good people of the forum, setting up nextcloud on my OMV5 machine, the first thing I want to do is a local mirror of the data drive so that I can just swap drives if disaster strikes. I have enabled the rsync job in System>Scheduled jobs, like so:


    rsync -av /srv/dev-disk-by-uuid-234ddefe-df8d-4d5e-91f9-8b0375a0d13f/ /srv/dev-disk-by-uuid-10ea8d36-b524-4e24-b461-6f04f4cd4581/


    I have purposefully omitted the --delete switch on the first run as advised in the user manual and for obvious reasons. Anyway, it looks like the job is a success, apart from an error at the end:



    Now, I am guessing that this means that there is a permissions problem in overwriting aquota.group and aquota.user on the destination drive, and I assume that I will need to overwrite these files for the mirrored data to be accurate.


    Can I just delete these files (on the source drive) through the CL and then run the job or will it run into this problem everytime it runs?


    Thanks,

    Nick.


    EDIT: Or can i just exclude them from the copy, will it make any difference as I'm not sure what those directories (aquota.group and aquota.user) are for?

    Another EDIT: OK, so excluding the files allows the job to run without errors. If this isn''t what i should be doing, please tell me. I will mark the thread as resolved.

  • Nick0

    Added the Label resolved
  • If you don't use quotas then the aquota.* files are not used and you can exclude them from your backups.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on ASRock Rack C2550D4I C0 Stepping - 16GB ECC - Silverstone DS380 + Silverstone DS380 DAS Box.

  • If you don't use quotas then the aquota.* files are not used and you can exclude them from your backups.

    I guess their purpose should have been self-explanatory, but no, I don't use quotas so will continue to exclude these files. Thanks for your help.


    I take it that you're using exclude statements? Such as --exclude='aquota.group' --exclude='aquota.user'


    Another question: As some point, did you turn user home directories turned on? (In Access Rights Management, User, in the Settings tab.)

    Yes, I am using rsync -av --delete --exclude 'aquota.group' --exclude 'aquota.user' /srv/dev-disk-by-uuid...


    I have never touched the home directories setting, so this is off.


    Thanks,

    Nick.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!