Installation guide states "Disconnect all disk devices..." before install

  • Why?

    I'm installing on a remote server via KVM Console, and I do not have physical access to the server. The server has twelve disk and one sata-dom for OMV. I can't disable the scsi controller i BIOS as the sata-dom is residing on it.

    The disk contains important data, and currently there is no backups available.

    Does the installer really delete all the disks or is it just a precaution? Are there any other mitigations i could use?

    /T

  • Why?

    OMV uses the entire disk that it installs on. It is possible (although unlikely) that a data disk could be used and it would be wiped. There are also some issues where grub is install on the boot record of the wrong disk and that disk is not bootable by the bios.


    Does the installer really delete all the disks or is it just a precaution?

    It only wipes the disk it is going to install on. As I mentioned above, that may be the wrong disk.


    Are there any other mitigations i could use?

    Install Debian 10 using the netinst iso first where you have complete control over the installer and the disks it uses. Then install OMV on top using the guide - Installing OMV5 on Raspberry PI's, Armbian SBC's, & i386 32-bit platforms

    omv 5.6.0 usul | 64 bit | 5.4 proxmox kernel | omvextrasorg 5.5.3
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • thk

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!