SMB 40MB/s slow read/writes on a gigabit network

  • hello to all,

    I have the existing setup:

    OMV5(fully up-to-date) on an ODROID XU4 arm SOC by hardkernel.

    Original power adapter from Hardkernel that can deliver up to 4A when needed.

    One USB 3.0 external HDD case that supports 2X 2,5" HDDs connected to the one from the USB 3.0 ports of the ODROID. This HDD case uses its own Power Delivery adapter so the system is not somehow burden from this or the disks themselves! The case is this…x_en.php?we_objectID=3239

    Samsung Evo Plus microSDXC 64GB U3 for the OS.

    2X WD 1TB blue 2'5" HDDs as a RAID 1(mirroring) configuration EXT4 fs (configured through the OMV web portal as OMV suggests).

    I am sure that most of you, using OMV you'll already know ODROID as Hardkernel recommends using it as a NAS solution among others. They also have a pretty good wiki on how to making the hole project come live from the easy process of building the image up to more advanced stuff...

    The overall experience so far(running this 24/7 for somewhat 1+ year now!) is very smooth and never have encountered disconnections/delays/random restarts/freezes neither to my running services(smb/dlna/urbackup/ftp/fail2ban/downloader) nor to the OMV server(disk failure/not responding) in general!!!

    The hardware monitoring is showing that even when I stream media OR/AND write/read form/to the OMV the memory/CPU bandwidth is more than enough!!!

    So the problem that I have is generally located with the smb protocol.

    I have the ODROID connected to a L2 managed gigabit switch and I have my PC WIN10(gigabit network adapter) on another port on that same switch. All the cabling is CAT6 and the only issue is the read/write performance of the smb protocol. I get only 40MB/s which is much below from the actual potentials of the hardware and the disks themselves!!!:cursing: As you can see here…as/eng/01_beginning#samba the performance if you use a gigabit network should be max out at about 90-100MB/s, which is correct and acceptable!!

    I already have checked the disks read/write speeds and I get something like 125MB/s. Also because I have the drives as a RAID 1 configuration through USB3.0, I thought that maybe that was the problem so I pluged in an WD green M2 128GB SSD NTFS fs on the other USB 3.0 port, and make it sharable again with smb protocol. The read/writes WAS WORST THAN THE RAID and I got only 20 MB/s, which I get it, as NTFS is not recommended firstplace(in WIN10 performs like 500MB/s read and 350MB/s write speeds just to clarify that). So then I reformatted it from NTFS to EXT4(configured through the OMV web portal) AND THE SAME BAD PERFORMANCE as the RAID's one CAME OUT(40MB/s) which is just NOT seems to be correct!!!

    So from all the above the problem doesn't seems to be either networking OR hardware OR RAID 1 performance on the slower HDD disks as the performance is pretty the same on the faster SSD. From my little experience the problem should be setting values on the SMB protocol(maybe some tweaks?).

    Please anyone can help with this as I run out of ideas... ?( and I really want to max my transfer speeds to the limits of my gigabit network!

    I'm surviving just pressing keycaps... 🤔weird ...!?

  • geaves

    Approved the thread.
  • Hi,

    there are "SMB Extra Options" that did the trick for my RPi4.

    They are listed in linked post in below signature

    omv 5.5.23-1 (usul) on RPi4 with Kernel 5.10.x and WittyPi 3 RTC HAT

    2x 6TB HDD formatted with ext4 in Icy Box IB-RD3662-C31 / hardware supported RAID1

    For Read/Write performance of SMB shares hosted on this hardware see forum here

  • Thank you for the quick reply mi-hol but I already have these and yet nothing more than 40-43MB/s!!!
    I forgot to mention that also the power management>monitoring option on the web-gui is set to OFF as the governor not working as expected on ARM processors!!! With that option enabled I was getting only 30-33MB/s while now 43MB/s...

    I'm surviving just pressing keycaps... 🤔weird ...!?

  • Have you tested some other protocoll like FTP or have you done a speedtest with iperf? This can help to check the network speed of you device and can be compared to the SMB speed. Also helpfull is to check the net speed with to other devices. Can you do the tests and post the results?

  • OK, so after all the issue was my PC network adapter. While 10/100/1000 there seems to be a hardware issue... I don't know exactly what but I replaced it and now I get 110MB/s READ and 60MB/s WRITE speeds. I tested it again with the m2 DISK and I get 110MB/s READ/WRITES so correct me if I'm wrong but I think the 60MB/s is due to the RAID1 mirroring configuration+ LUKS encryption that I'm using on both disks?

    I'm surviving just pressing keycaps... 🤔weird ...!?

  • I don't know exactly what but I replaced it and now I get 110MB/s READ and 60MB/s WRITE speeds.

    If you don't know exactly what you did, there's no way a forum user could figure out the issue from remote.


    You had a lot of moving parts involved in this problem.

    A few examples:

    - NTFS (If going for top speed, using a native Linux file system is a given.) You fixed that.

    - Windows client hardware and the "Windows" OS in general. (It's nearly impossible to know the state of health of a Windows client. They slow down considerably after a few years of use, they may have malware installed, etc. This one item, a Windows client, is an enormous variable.)

    - Software RAID1 mirroring + LUKS (While minimal, Software RAID, along with LUKS, does incur a slight CPU penalty. Without knowing what else is running while speed tests are conducted, well, it's all guess work. Even among the faster models, ARM CPU's are relatively easy to stress.

    - The "X" factor. The chipset used to bridge SATA to USB3. There's considerable performance variation, depending on the bridge. Some are good, others are not.

    But you fixed it so, as they say, all's well that ends well. (Whatever it was.) :)


    I can say this. If I was you, I'd dump LUKS and RAID1. LUKS provides physical protection, from hard drive theft, ONLY. If you're not worried about a thief breaking in and stealing your hard drives, LUKS is not doing you any good.

    RAID1 is not doing you any good either. You have two disks in RAID1 where, for home use, nothing is being accomplished. The second disk would be far better utilized for backup, as opposed to RAID1.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!