Windows Virtual Machine on OMV 5

  • Hey everybody


    I want to build a Virtual Machine (Windows 10) on my NAS. On my NAS is OMV 5 installed.

    I found this guid.

    https://medium.com/axon-techno…er-container-c78e4c3f9ba1


    But the problem is at point 7, it can't locate the package. This is the message:

    Code
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-image-5.9.0-0.bpo.5-amd64
    E: Couldn't find any package by glob 'linux-image-5.9.0-0.bpo.5-amd64'
    E: Couldn't find any package by regex 'linux-image-5.9.0-0.bpo.5-amd64'

    I don't kow what i am doing wrong. Is there a way to make a VM with Windows 10 on OMV 5?

    Thank you, for your help.

    Schmedi

  • geaves

    Approved the thread.
  • Ooh that is sad...
    I saw this guide but can I install Windows 10 with this guide? I could not do that. I need a Windows 10 VM because i want to run a program on it and this programm is for Windows 10.

  • Okey then i will try this. But what do i have to chose in the installation source? I tried it once ond I became this message:

    ERROR Could not find an installable distribution at '/dev/sdf1' The location must be the root directory of an install tree. See virt-install man page for various distro examples. Domain installation does not appear to have been successful. If it was, you can restart your domain by running: virsh --connect qemu:///system start BimBamBum otherwise, please restart your installation.

  • But what do i have to chose in the installation source?

    The section 16 explains how to do this, that error related to fact that it cannot locate an iso in /dev/sdf1, you need to look in /srv then on the drive/share you have placed the iso.

    Raid is not a backup! Would you go skydiving without a parachute?

  • Hey i now could start the installation of Windows 10 on the VM. But it doesn't find a Driver and i can't select one. When i click on scan this is what i can see:


    But when I click on one folder this error message appears:

    What is wrong this, why can't i select something.

  • Having installed Windows more times than I can remember I have never known it ask for a driver during an installation, but that's on direct hardware, but this shouldn't be any different.


    As the screen shots are in your language I can't translate, but to me in the first image you would select ESD-ISO as I assume this is the Windows iso installer.

    Raid is not a backup! Would you go skydiving without a parachute?

  • Aah I now found out what was the problem with the driver. I had to change the the bus to sata of the data medium in the VM settings. Now i am having a running Windows 10 VM.

    But i can't go in the internet with the VM. Does someone know what to do? I have made the settings with the bridged network as it is explained in the Guide.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!