Help please solving premissions issue SOLVED

  • Hi, I hope someone can give me some pointers on what to try / who to ask next to solve my issue


    I have set up my first omv (5) basic home server. I started by following Technodad videos and reading omv guides and forum. I have the server set up with two shared folders on separate drives. I have successfully transferred data to those folders and the permissions have been set fully open for now while I learn the permissions side of things.


    I have hit the following issue that I'm struggling to get my head around to find an answer to and would appreciate any pointers on where to look to resolve.


    The folders are shared via SMB/CIFS, as although I use Linux I need access from android and windows for my family members.


    Having installed the data I can browse (connecting as anonymous) to the shares. I can open subfolders on the share. I can create a folder and file in any of the existing subfolders of the share. But if I then try to create a subfolder or file in the folder I just created I get a permission denied error. If I use reset perms on the share it solves the permission error but only for that instance.


    I see this issue using:-

    desktop installed Linux Mint Cinnamon 19.3

    desktop installed Linux Mint XFCE 20.1

    Xubuntu 20.04.1 live CD

    Fedora 33-1.2 live CD


    I do NOT have this error using:-

    Android phone

    Windows 10 laptop

    deepin 2014.1 livecd



    At first I thought it may be a Linux Mint / ubuntu issue until I fount it also present using the Fedora Live CD (which I believe is based on RedHat and not ubuntu).


    Any thoughts anyone?


    Thanks for taking the time to read.

  • I forget if it’s in shared folders tab or SMB tab but did you check “recursive” when creating the share?

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • Hello


    Did you try to add a specific user to access your share to check if it's the same problem ?


    Check if on you linux os you have 'cifs-utils' installed ?

    Code
    dpkg -l | grep cifs

    Sois le changement que tu veux voir - le bonheur n'est vrai que partagé - l'essentiel est invisible à nos yeux ;)

  • I forget if it’s in shared folders tab or SMB tab but did you check “recursive” when creating the share?

    Thanks Agricola for taking the time to read my post.

    I had a look and couldn't find a recursive option but did find in the SMB "edit" for the share an "Enable permission inheritance" option which I took to mean a similar thing, and yes, selecting that and re-saving the share cured the issue on the Mint Cinnamon box and with the Fedora Live CD.

    The description in the OMV SMB share edit says that this option overrides the "create mask and directory mask" which "normally govern permissions on new files". It also says that "this may be useful on systems with many users to allow a single share to be used flexibly by each user". This does not apply to me at this stage but it would once I let my family loose on the shares!

    Please don't get me wrong, I am very grateful your suggestion fixes the issue but I can't help feeling that, at this stage with just me as a user, it is treating the symptom rather than the cause - would you agree with that?

    I understand that SMB is a go between for windows and linux, but as omv is linux based it seems strange to me (I still consider myself a linux novice) that it's only (some) linux distros that had the issue whereas windows, android and Deepin linux did not.

    Perhaps that's a question I should post to the Mint/Xubuntu forums?

    Do I really need to know the cause if my issue is fixed? perhaps not, but I'm curious to learn. Perhaps lockdown will give me time for some more googling :-)

    Thanks again for your suggestion

  • Hello


    Did you try to add a specific user to access your share to check if it's the same problem ?


    Check if on you linux os you have 'cifs-utils' installed ?

    Code
    dpkg -l | grep cifs

    Hi sirga784

    I didn't / haven't tried adding a specific user as I'm not yet at the stage where I need to add specific users. I do intend to set up a second server soon for testing once I've got this basic one operational so will try that but for now with Agricola's suggestion I have the functionality I need, if not the understanding of the cause.


    I do have cifs-utils installed on the Cinnamon box. I installed it in order to set up a share on the Cinnamon box prior to starting on my OMV build

    Thanks for taking the time to consider my problem and your suggestions

  • Having installed the data I can browse (connecting as anonymous) to the shares.

    A closer look at your first post made the above quote pop out at me. This combined with the question from sirga784 above makes me think that you need to set up some users and give them various permissions (either under the Users tab or the Shared Folders tab) and then uncheck "guests allowed" in Samba shares. In Permissions give one user "read/write", one "read only", and one "no access" and see what you can and cannot do. If you do want guests to be able to access your Samba shares create a "guest" user with the password "guest" and give him "read only" privileges for the Shared Folders you want him to have access to, and "no access" to the Shared Folders you do not want him to have access to. Even though I always check "guest's allowed" (that is how I learned it) I have wondered why, if you had multiple users in the home or your workplace, why would you want to have guests (whatever that means) to be allowed to access your samba shares. This thread has made me think I want to go back to all of my Samba shares and uncheck "guests allowed." Anybody else "trolling" around want to add your two cents on this? I would like to know what some of you grey beards think about this issue.

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • I have wondered why, if you had multiple users in the home or your workplace, why would you want to have guests (whatever that means) to be allowed to access your samba shares. This thread has made me think I want to go back to all of my Samba shares and uncheck "guests allowed." Anybody else "trolling" around want to add your two cents on this? I would like to know what some of you grey beards think about this issue.

    Hi Agricola

    Your suggestions and comment are valid, but do take this thread off in a different direction (management of shares) to that of my original (technical) issue. It remains unanswered why some of my systems had the issue and others not. If there are no technical explanations for the issue forthcoming in the next few days I could try posting that question on a SMB specific forum and mark this thread as solved as I now have a workaround thanks to your original suggestion.:)

  • If it was me, I would try to mount the share manualy using command line, checking some differents smb version ?


    Code
    mount -t cifs -o rw,vers=3.0 //omv-server/<share_name> /mnt/<local-linux-folder>
    mount -t cifs -o rw,vers=2.0 //omv-server/<share_name> /mnt/<local-linux-folder>
    mount -t cifs -o rw,vers=1.0 //omv-server/<share_name> /mnt/<local-linux-folder>


    To check if it the same when mounting a share with gui vs command line

    Sois le changement que tu veux voir - le bonheur n'est vrai que partagé - l'essentiel est invisible à nos yeux ;)

  • If it was me, I would try to mount the share manualy using command line, checking some differents smb version ?


    To check if it the same when mounting a share with gui vs command line

    Hi sirga784, I appreciate you taking time to consider this issue.To quote from the OMV5 New User Guide

    "One of the ambitions of the openmediavault project is to make advanced NAS
    technologies and features available to inexperienced users in an easy to
    use web interface, thereby making it possible for people, without extensive
    knowledge of Linux, to gain easy access to advanced technologies."

    I'm afraid I currently fall into that target user group of "inexperienced users" and don't feel my Linux skills are yet up to a level required for command line intervention on a system designed for configuration via a web interface :(

  • miniyard

    Added the Label OMV 5.x
  • miniyard

    Changed the title of the thread from “Help please solving premissions issue” to “Help please solving premissions issue SOLVED”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!