Ryzen 3200G boot issues - ASUS B450 MB

  • New to OMV but experienced in Ubuntu and Centos.


    Doing a new install on a brand new system - the system has 16GB of Corsair ram, ASUS B450 mATX MB and a Ryzen 3200G processor.


    I think the problems i am having are to do with the 3200G processor.


    During boot to USB to do the initial Install - once the install option is selected - the graphics are scrambled and the scrrne becomes unreadable - replaced the screen and cable and then moved from DVI to HDMI - still the same result.


    Open Googling found that an option needed to be set in the install script that changed the VGA mode to 322 - did this and the installl went through without a problem.


    However on first boot - there is a message that scrolls by re IOMMU - which i ibelieve is to do with the CPU VT being disabled - so i re-enabled that in the BIOS. However the system then hangs (no keyboard response etc with a blank screen and goes no further.


    Anyone else experienced this with this processor ?


    Craig

  • Highly likely the Vega processors appear not to play nicely with Linux, however one option might be try the Debian netinstall enable ssh only, then run the install script from here

    Yep looks like that could be it - will do some more digging around blacklisting to see if i can come up with a solution. Its not really a Vega processor not playing nice - the reality is that this version of Debian was frozen before these guys came out. WIll have to work through the options


    Craig

  • OK thanks for the pointer - it is indeed a video driver issue.


    The easiest fix (to get past the boot issue - not sure about ongoing stability - still to be tested) - is to edit the grub boot entry and change the quiet option to nomodeset (which for anyone else looking in future - removes the GPU control from the Kernel and hands it back to the BIOS during the boot proces)


    At boot time - when the grub menu comes up - press E and this will interrupt the boot process and enable you to change the line ending in quiet to nomodeset


    Note this is not a permanent change - you must edit and write the grub.conf file to retain these changes - look for the grub2 entries in the below


    https://wiki.debian.org/Grub#:…0GRUB%20configuration,lst.


    Craig

  • *typically* in my experience, Nomodeset will not cause instability. My laptop still requires it to this day for some reason (and I've used various versions of Linux on it for years)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • *typically* in my experience, Nomodeset will not cause instability

    I knew there was a way around this just couldn't remember, most searches were throwing issues with the graphics rather than the boot process.

    Raid is not a backup! Would you go skydiving without a parachute?

  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!