omv-extras repos moving to github

  • Can you please be a bit more precise? I read the whole thread, but the proposal in #12 doesn't really seem to fit. I think I don't have a file

    /etc/apt/sources.list.d/omvextras.list.


    Probably because I am still in a OMV 4 version.

    I could remove omv-extras-org.list at the given location.


    dumalkin wrote that he did how proposed (#14), but ended up with the same error message than me. The advice from ryecoaaron was to follow post #1.


    I am a little bit confused.

  • Ok, understood.


    I had had the impression that #9 was a specific solution for a very individual problem. I was not aware that the following is the

    general way to update the omv-extras repos url to the new github location for OMV 4.x.



    I'll give it a try.

  • had had the impression that #9 was a specific solution for a very individual problem. I was not aware that the following is the

    general way to update the omv-extras repos url to the new github location for OMV 4.x

    Nope. I didn't make it better because many people would just use it to stay on 4.x instead of upgrading.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I know this thread is a little old...

    I'm having problems with apt update...

    I'm on OMV 4 (Debian 9.13)

    I'm stuck on this step "sudo apt-key add omvextras2026.asc"

    I'm getting "gpg: no valid OpenPGP data found."

    And when I run "sudo apt-get update"

    I get:

    I think I want to upgrade to OMV5, but I'm afraid that my data (UrBackup, that is not in Docker) will be gone...

    And if my data is safe, what do I upgrade first, OMV or Debian?

    Thanks for the help

  • omvextras2026.asc.1 100%[========================================================================================================================================>] 2.24K --.-KB/s in 0s

    2021-09-07 09:45:06 (33.6 MB/s) - ‘omvextras2026.asc.1’ saved [2289/2289]

    root@storage:/etc/apt/trusted.gpg.d# sudo apt-key add omvextras2026.asc
    gpg: no valid OpenPGP data found.

    You need to change the filename for the key you are adding to the filename that was downloaded. It added a .1 to the end.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • You need to change the filename for the key you are adding to the filename that was downloaded. It added a .1 to the end.

    Thanks.

    I guess that's because I tried it already...

    But I still get an error

  • weakref.py is just a warning. Ignore it.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • weakref.py is just a warning. Ignore it.

    OK.

    So my system is good new?

    I don't have any updates... (I didn't have updates for a while now)

    I think I want to upgrade to OMV5, but I'm afraid that my data (UrBackup, that is not in Docker) will be gone...

    And if my data is safe, what do I upgrade first, OMV or Debian?

    What about upgrading?

    What goes first?


    Thanks

  • So my system is good new?

    Yes.


    don't have any updates... (I didn't have updates for a while now

    That is because you are using a very old release.



    What about upgrading?

    What goes first?

    They go together. Upgrade Scripts for non-interactive major release upgrades (2->3, 3->4, 4->5)

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • threeeye

    weakref.py is just a warning. Ignore it.

    If you want, you can solve this "warning" with this command from SSH (with sudo if necessary) :

    Code
    curl -L https://raw.githubusercontent.com/python/cpython/3.5/Lib/weakref.py > /usr/lib/python3.5/weakref.py

    OMV 4x - Core i3-8100 - 3.6 GHz - RAM 32GB - HDD 6x 2TO (3x Raid1)

  • Hello - I tried the in post #12 discribed procedere several times and I always get the following errors.

    Hope you can help me. Thanks




  • Hello - I tried the in post #12 discribed procedere several times and I always get the following errors.

    Hope you can help me. Thanks

    You have to run it as root.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hello,


    I have read all the posts of this thread but I have not found a solution that applies exactly to my case, do you have an

    do you have a solution ?

    Code
    apt-key add omvextras2026.asc
    gpg: no valid OpenPGP data found.
    ls
    armbian.list openmediavault-kernel-backports.list raspberry.list
    omvextras2026.asc openmediavault.list
    omv-extras-org.bak openmediavault-local.list

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!