Update of omv-extras 5.5 failed

  • hi guys,


    today i started update and couple of omv-extras plugins dissapeared. in log i see following errors:



    any advice? thx

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

  • The new code (hence why it is in testing) downloads the gpg key for each repo from the web. Your system is failing to do that.


    What is the output of: wget https://openmediavault-plugin-developers.github.io/packages/omvextras2026.asc

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • now im geting this error, when i want to search for updates:

    Code
    backup-server.local
    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; apt-get update 2>&1' with exit code '100': Get:1 file:/var/cache/openmediavault/archives InRelease Ign:1 file:/var/cache/openmediavault/archives InRelease Get:2 file:/var/cache/openmediavault/archives Release Ign:2 file:/var/cache/openmediavault/archives Release Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Ign:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Get:3 file:/var/cache/openmediavault/archives Packages Get:4 file:/var/cache/openmediavault/archives Translation-en Ign:4 file:/var/cache/openmediavault/archives Translation-en Hit:5 http://ftp.debian.sk/debian buster InRelease Hit:6 http://ftp.debian.sk/debian buster-updates InRelease Hit:7 http://packages.openmediavault.org/public usul InRelease Hit:8 http://security.debian.org/debian-security buster/updates InRelease Hit:9 http://httpredir.debian.org/debian buster-backports InRelease Hit:10 https://openmediavault.github.io/packages usul InRelease Get:11 https://openmediavault-plugin-developers.github.io/packages/debian usul-testing InRelease [3920 B] Get:12 https://openmediavault-plugin-developers.github.io/packages/debian usul-extras InRelease [3918 B] Err:11 https://openmediavault-plugin-developers.github.io/packages/debian usul-testing InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 326A835E697B890A Err:12 https://openmediavault-plugin-developers.github.io/packages/debian usul-extras InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 326A835E697B890A Reading package lists... W: GPG error: https://openmediavault-plugin-developers.github.io/packages/debian usul-testing InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 326A835E697B890A E: The repository 'https://openmediavault-plugin-developers.github.io/packages/debian usul-testing InRelease' is not signed. W: GPG error: https://openmediavault-plugin-developers.github.io/packages/debian usul-extras InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 326A835E697B890A E: The repository 'https://openmediavault-plugin-developers.github.io/packages/debian usul-extras InRelease' is not signed.

    Should i disable the testing repo? Im using OpenVPN from there. Thx for help

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

  • now im geting this error, when i want to search for updates:

    My command wasn't supposed to fix anything. I just wanted to see if something on your network was blocking the location.


    Should i disable the testing repo?

    No. You need to revert to the previous omv-extras version until I can figure it why this code isn't going to work on some systems. grrr...

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Can you run the following command on your system before you downgrade and post the output?


    sudo salt-call -l debug --local --retcode-passthrough state.apply omv.deploy.omvextras

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • No. You need to revert to the previous omv-extras version until I can figure it why this code isn't going to work on some systems. grrr...

    Thx and pls how to go back to omv-extras 5.4.5 ? Can i download it from somewhere?


    BTW i have same issue on both servers, one is VM and one is old laptop.

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

  • Can you run the following command on your system before you downgrade and post the output?


    sudo salt-call -l debug --local --retcode-passthrough state.apply omv.deploy.omvextras

    here is the output:

    output.txt

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

  • here is the output:

    Excellent. Can you try the following:


    sudo apt-get install gnupg

    sudo omv-salt deploy run omvextras


    If this works, you won't have to downgrade and I can fix the package.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • seems to work:

    so now what to do next? can i check for updates? or wait for new package?

    omv 5.6 in proxmox 6.3-6 - AMD Ryzen 1700 - 16GB DDR4 :thumbup:

  • o now what to do next? can i check for updates? or wait for new package?

    Your system is fixed. If you want to check for updates, it should work.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Mio

    Added the Label resolved
  • Thanks for the help. 5.5.1 is in the testing repo that should prevent this now.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Is this anything I need to get worried about and any suggestion on how to fix this please?

    The solution is in this thread. You need to follow #8 above.

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • The solution is in this thread. You need to follow #8 above.

    Hello,

    I have the exact same problem as both of the users above, same output, same everything, and your solution did not work for me.
    I'm running the latest version of OMV (updated via distr-upgrade), on Raspberry PI OS (Debian 10) 64 Bit, everything is the latest.


    gnupg was already installed, so I purged and reinstalled it (didn't change anything)

    And here's a truncated output of sudo salt-call -l debug --local --retcode-passthrough state.apply omv.deploy.omvextras

    Code
    ----------
    ID: omvextrasbaserepo
    Function: pkgrepo.managed
    Name: deb https://openmediavault-plugin-developers.github.io/packages/debian usul main
    Result: False
    Comment: Failed to configure repo 'deb https://openmediavault-plugin-developers.github.io/packages/debian usul main': Error: failed to add key from https://openmediavault-plugin-developers.github.io/packages/omvextras2026.asc
    Started: 19:36:07.027642
    Duration: 2141.546 ms
    Changes:
    ----------



    Isn't there a easy solution for this? can't we manually import those missing keys?

    thanks.



    EDIT:

    Well that was quick, I fixed my issue by manually deleting '/etc/apt/trusted.gpg.d/home:Provessor.gpg' , that was the first problematic item in my truncated log.
    So if anyone runs into the same issue as me, give it a shot :)

    Edited once, last by haram27: Problem resolved ().

  • Isn't there a easy solution for this?

    Uninstall the plugin and then re-install. As root:

    apt-get purge openmediavault-omvextrasorg

    wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash

    can't we manually import those missing keys?

    What do you think the plugin does? That is its main purpose is to install the keys.

    gpg: invalid key resource URL '/etc/apt/trusted.gpg.d/home:Provessor.gpg'

    It looks like you have a bad key on your system caused by something you did (no idea what).

    omv 5.6.9 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.5
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • i was in the same boat as OP.


    i used wget to manually download replacements of the troublesome keys and install them with $ gpg --import my_fresh.gpg


    then the steps in post #8, and the update management in the admin UI worked without any errors.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!