New openmediavault-kvm plugin

  • This is a limitation of macvtap. You need to setup a bridge. There are few posts about that in this thread.

    This could be your server or storage or how you are connecting. The consoles provided by the plugin are only meant to use for setup. You should use the native RDP server on Win 7 (which is EOL by the way).

    I did it on the advice. Delete the interface in the GUI without clicking apply, added the BRIDGE, and all the other default settings(DHCP for the interface, etc.), then clicked apply and lost the connection. I had to physically go to the server and restore the network interface through omv-firstaid

    OMV 5, Motherboard: Intel DP55WG, CPU: Intel Xeon X3470, 12GB RAM, WD Black WD5000LPSX - system, WD Blue 2GB x4 RAID ext4 for data, 1x500GB SSD VM's,

    Installed Emby server, netdata monitoring, kvm plugin, nextcloud snap, a couple of VM's

  • Hello, I need help getting the virtual machine to communicate with the host :-))

    My use case is this: I run HomeAssistant as a VM using KVM and I simply need it to access both the OMV server and OMV samba shares.

    I've read this topis and this is what I've done:


    1. created a bridge in OMV interface using eno2 (my server has 2 NICs so I was able to do that)



    2. created a new VM and in network I chose "bridge" and br0


    unfortunately, when the VM starts, it has no IP (I see this in the console) - although the OMV server is connected also through eno2 (I see this in the router)



    please help, I've already spent a full day trying to understand what is going on before finally reading here that VM does not see the host if using the macvtap bridge


    and it's really important for me to have the VM see the OMV server

  • Hello, I need help getting the virtual machine to communicate with the host :-))

    One way to do this is to add another network interface to the VM. The VM would have two network interfaces. With the default interface the VM sees the host. With the macvtap interface the VM has an IP on your local network.

    Maybe there is an easier way to do it, I only know this one.

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

    Edited once, last by chente ().

  • chente

    thanks for the reply, I tried that but it did not work - the VM gets an ip in the range 192.168.122.X and I cannot access it - I need it to be 192.168.0.XX


    but indeed, from the console I can now ping the OMV server and it replies; also the router replies, but I do not know how to access the VM


    these are the KVM networks - as you can see the default network is configured with DHCP, probably that's the problem

  • thanks for the reply, I tried that but it did not work - the VM gets an ip in the range 192.168.122.X and I cannot access it - I need it to be 192.168.0.XX

    I do not know homeassistant and I do not know how to configure the network in this system.

    The point is that this has worked for me in an Ubuntu VM. I leave the default interface as is (in DHCP). Through this interface an IP in range 122 is assigned to the VM. And this network is used to see the host (and the shared resources of the host).

    The bridge interface must be configured within the VM to request a fixed IP from your DHCP server (usually your router). This way you will also have access to the rest of the local network, and you will be able to access your VM from the local network.

    It is similar to having two separate "network cables" on the VM.

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

  • when a VM is set to autoboot with host, then the allocated VNC port is 5900. This get a conflict with a docker container i have running. Can the VNC start port range be modified somewhere?

  • Hi,

    Currently testing this add on and I have an issue creating a Ubuntu 18.04 VM. Using the standard options, it fails to load, when checking the system log, I get the following error


    libvirtd[650]: invalid argument: could not find capabilities for arch=x86_64 domaintype=kvm


    I have tried looking around the forum, but couldn't locate anything.


    Thanks

  • libvirtd[650]: invalid argument: could not find capabilities for arch=x86_64 domaintype=kvm

    does your CPU support virtualization? And did you activate it in your BIOS?

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

  • when a VM is set to autoboot with host, then the allocated VNC port is 5900. This get a conflict with a docker container i have running. Can the VNC start port range be modified somewhere?

    libvirt should pick a port that isn't in use since the plugin is set to auto choose the port. You can always change the xml to force a specific port.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • libvirt should pick a port that isn't in use since the plugin is set to auto choose the port.

    i guess this has to do with the start priority. If libvirt starts before docker, the port is available. then docker has an access problem afterwards. So, if there is no libvirt, start at 590x port value, the xml edit way semms the only one useful.


    BTW: even though the KVM plugin has a "edit XML" option. Editing isn't really possible. difficult to describe but just impossible. Needed to go the virsh edit route.

  • does your CPU support virtualization? And did you activate it in your BIOS?

    Surprisingly, That was the issue.


    I say surprisingly, as I was running VMWARE before OMV and didn't change the settings when installing OMV. I was able to run VM's on Cockpit as well. So not sure why it was disabled or worked on other software. Anyways good catch!

  • Surprisingly, That was the issue.


    I say surprisingly, as I was running VMWARE before OMV and didn't change the settings when installing OMV. I was able to run VM's on Cockpit as well. So not sure why it was disabled or worked on other software. Anyways good catch!

    I am no expert, I just googled the error ;)

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

  • I say surprisingly, as I was running VMWARE before OMV and didn't change the settings when installing OMV. I was able to run VM's on Cockpit as well. So not sure why it was disabled or worked on other software

    The plugin does make the assumption that virtualization is enabled. Otherwise you are using slow qemu. But just remember that the plugin and cockpit both use libvirt. VMware is completely different but you really would want it enabled there too.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Hi!Tell me, did you manage to solve the problem so that the host could see the virtual machines and vice versa?Since I haven't managed to do it yet

    OMV 5, Motherboard: Intel DP55WG, CPU: Intel Xeon X3470, 12GB RAM, WD Black WD5000LPSX - system, WD Blue 2GB x4 RAID ext4 for data, 1x500GB SSD VM's,

    Installed Emby server, netdata monitoring, kvm plugin, nextcloud snap, a couple of VM's

  • Hi!Tell me, did you manage to solve the problem so that the host could see the virtual machines and vice versa?Since I haven't managed to do it yet

    It's very simple, but I don't think I explain it well. Just add another network interface to the VM from the OMV GUI. In this way the VM will have two network connections. A "default" connection and another bridge connection.

    Start the VM and from within the VM configure the connection "bridge" with a fixed IP in the range of your network.

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

  • It's very simple, but I don't think I explain it well. Just add another network interface to the VM from the OMV GUI. In this way the VM will have two network connections. A "default" connection and another bridge connection.

    Start the VM and from within the VM configure the connection "bridge" with a fixed IP in the range of your network.

    Now my VM's works through macvtap-bridge and i have this adapter. so, i need to add default adapter?

    OMV 5, Motherboard: Intel DP55WG, CPU: Intel Xeon X3470, 12GB RAM, WD Black WD5000LPSX - system, WD Blue 2GB x4 RAID ext4 for data, 1x500GB SSD VM's,

    Installed Emby server, netdata monitoring, kvm plugin, nextcloud snap, a couple of VM's

  • Now my VM's works through macvtap-bridge and i have this adapter. so, i need to add default adapter?

    Yes, both adapters at the same time. Default and bridge.

    OMV 5, Intel core i3 3225, 8GB RAM, PendriveUSB system, ZFS RaidZ 5xWD Red 4TB, 1x120GB SSD Docker

    Tomorrow you will wish you had made a backup today !!

  • Hi!Tell me, did you manage to solve the problem so that the host could see the virtual machines and vice versa?Since I haven't managed to do it yet

    yes, i did manage to solve it


    1. create a bridge network in OMV interface, but give it a STATIC IP - it did not work for me without a static IP (mask = 255.255.255.0, gateway = your router, dns = 8.8.8.8)

    you of course need to firts delete the existing eno1 interface, DO NOT HIT SAVE, then create the bridge, and only then hit SAVE


    then wait for the OMV machine to reconnet, check the router, if there is already an addres reservation in the router make sure it is the same IP that you configured in the OMV bridge


    2. create a new VM and in the network section choose "bridge" then the bridge created in OMV (it will probably be named "br0")
    you cannot attach a bridge to an existing VM because there is no option for that, it can be done only when you first create the VM

    and it should work, at least for me it did work

    regarding chente solution, it did not work for me even if the IP was configured as static within the VM (Home Assistant), but maybe it works for you

  • Thanks! Ie, in the OMV interface, when creating a bridge, specify the same IP that is issued by the router, only specify the IP in the interface not DHCP? For example, for OMV, the Ip router turned out to be 192.168.88.5, I specified it on the router as a static constant for this device.It turns out that I will write this address in the bridge in the OMV interface? I will be happy if it works! In the evening I will check and write about the result.

    OMV 5, Motherboard: Intel DP55WG, CPU: Intel Xeon X3470, 12GB RAM, WD Black WD5000LPSX - system, WD Blue 2GB x4 RAID ext4 for data, 1x500GB SSD VM's,

    Installed Emby server, netdata monitoring, kvm plugin, nextcloud snap, a couple of VM's

  • yes, you need to put a STATIC IP in the OMV interface (and mask and gateway etc)


    if you already have an IP reservation in the router, then it needs to be the same IP, otherwise the OMV machine will request an IP but the router reserved another IP so they might not understand each other


    alternatively, you can delete the IP reservation from the router, but in my experience it is better to leave it also there so that the router does not assign it to some other device when OMV is shutdown or disconnected.

    this is how I have it in OMV - 192.168.1.14 is the IP of the OMV machine and it is also reserved in the router


    PS don't forget to also put DNS 8.8.8.8 in the OMV bridge; this is not required for the VM, but it avoids some issues on the OMV side in general (i.e. radarr/sonarr sometimes do not work without this)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!