SMB/CIFS on Win 10 v 20H2 Home or Pro doesn't work

  • I am on my 3rd rebuild of OMV 5.n. Nothing I do allows a network connection to an OMV shared folder.

    I have turned OFF SMB 1.0 as OMV 5.n uses SMB 2.0-3.0

    I have created OMV users same as Win 10 (cams and passwords)

    I have tweaked registry all to now avail. Checked FireWall, etc.

    I can SEE the RPi OMV device but can't get to the shares. I have even tried using WINS.

    And, the OMV IP and Hostname are in the hosts file.

    I get a Win 10 error 35 or it hangs.

    And, now, with 128bit and password turned off it crashes File Explorer.

    But, OMV works great on my Android Note 10. Totally polite...

    Microsoft broke the product, probably deliberately as they want everyone to use the Microsoft cloud, not your own.

    If anyone comes up with a solution please post.

    OMV worked great on my Win 10 Home PC pre version 20H2.


  • All my Windows 10 machines at home are Pro with the latest update 20H2 and I don't have a problem.

    So lets start with something simple, from a command prompt on a non connecting W10 can you ping the ip address of the Pi

    Raid is not a backup! Would you go skydiving without a parachute?

    OMV 5x amd64 running on an HP N54L Microserver

  • Found a ssolution:

    On your Win 10 SMB settings change the SMB 1.0 and uncheck the SMB 1.0 /CIFS Server

    Then, use CMD (as admin ) command "Net Use A:* \\192....\Homes

    User name (one created on OMV )

    and the password.

    So far this works.

    * A: and B: are valid devices...

  • Hi,

    I've the same problem with Windows 10 Pro 20H2 (19042.985). :cursing:

    I can't connect to any shares on my OMV5. It works with a previous Windows version or from a Mac Book Pro.

    And it was OK before the 20H2 installation.

    I tested as proposed but it doesn't work ;(

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!