Can't add second NIC

  • Hi, a few years ago I build my own NAS using OMV. It's an old i3-2120 CPU with 4 GB of RAM and an mini-ITX Intel motherboard. At first I was using OMV 4 for quite some time until a stable version 5 was released and I switched to it :) I did a fresh new installation from scratch and everything was just fine. Had no issues until today when I decided that I want to use a spare but fully functional Supermicro gigabit NIC I had laying around. So, I installed the NIC, hooked up the additional cat5e cables, powered on the machine and went straight to the web gui to create a bond connection. Network -> Interfaces -> Add -> Bond -> select desired ports -> mode: 802.3ad -> turned on DHCP -> turn on wake on lan -> Save -> Apply changes and that's where the error appear:

    Code
    Error #0:
    OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-salt deploy run --no-color collectd 2>&1' with exit code '1': debian:

    It does that every time whatever I try to do with any of the network interfaces. Even using omv-firstaid to reconfigure my existing connection resulted with this error. Adding single ethernet interface - same error. I did try ip addr flush dev eno1, then reboot, omv-firstaid again but resulted with the same error.

    I do updates every time when update manager says there is an available updates, so I'm up to date.

    So good and knowledgeable people, can anyone point me in the right direction? Or maybe straight to the problem? ;) Just bare in mind that I'm a linux beginner but totally not a beginner when it comes to computers :)


    P.S.: As the message becomes way too long when I add a full error report - here is a link to it: https://pastebin.com/raw/2f1ZU9WT

  • KM0201

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!