Cannot assign imported user to groups. Error message: "The group '...' does not exist."

  • The background of this post is that I am trying to mount an NFS share using Finder on Mac OS Big Sur (version 11.2.1). I can successfully connect to the share and browse directories using Finder, but I cannot add any files to the share. The share is set up on OMV using read/write privileges and options subtree_check,insecure,all_squash,anonuid=1001,anongid=100. uid 1001 and gid 100 belong to my OMV user that has read/write privileges on the shared folder in question. Finder successfully connects to nfs://<static IP>/export/<share>/ and as said before I can browse directories but not add any files.

    Based on other posts I understand that the reason for this problem is that my Mac OS user ID and group ID do not match the uid and gid of the OMV user that has read/write privileges on said shared folder. Hence I created two new gids and tried to create a new user in OMV for that shared folder, whose uid and gid I was going to match with the uid and git of my Mac OS user.

    I was able to create two gids as follows:

    group 1 with gid 502 (by importing a group using syntax <name>;<gid>;<comment>)

    group 2 with gid 1001 (by adding new group and have OMV assign its own gid)

    Next, I am trying to import a new user using syntax <name>;<uid>;<comment>;<email>;<password>;<shell>;<group,group,...>;<disallowusermod>. More specifically, I am trying to import user <new username>;<501 = my Mac OS uid>;;;<new password>;/bin/sh;<502 or 1001 = either of the two gids created above>;0

    However, when I try to import this user on OMV with either of the two gids created above, I get the following error message: "The group '<502 or 1001>' does not exist."

    However, if can see that both groups have been created, and I can assign existing users to either of the new gids. I can also run command id <username> on that existing user to confirm that gids 502 and 1001 do in fact exist. Rebooting several times did nothing to solve the issue.

    Any hints as to why OMV claims that the new groups do not exist?

    UPDATE: After another attempt at mounting my NFS share with write access on Mac OS I succeeded. The only changes I made were:

    • to assign my existing OMV user to one of the new gids (1001);
    • to create a new group with the same gid (1001) on Mac OS and add my existing Mac OS user to that group (which also happens to match anongid=1001).

    For lack of better understanding I assume that these changes solved the original problem. Perhaps it was just the second change that did the trick.

    But since this objective was just the background of my post, and the actual topic of failing to import a new user remains unresolved, I will leave this question open.

    Edited once, last by robster23: Found a way around the overarching problem, but the actual topic of this post remains unresolved. ().

  • This is the detailed error message from OMV:

    Error #0:
    OMV\AssertException: The group '1001' does not exist. in /usr/share/php/openmediavault/system/
    Stack trace:
    #0 /usr/share/openmediavault/engined/rpc/ OMV\System\Group->assertExists()
    #1 [internal function]: Engined\Rpc\UserMgmt->setUser(Array, Array)
    #2 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #3 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->callMethod('setUser', Array, Array)
    #4 /usr/share/php/openmediavault/rpc/ Engined\Rpc\UserMgmt->Engined\Rpc\{closure}('/tmp/bgstatusQM...', '/tmp/bgoutputvK...')
    #5 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
    #6 [internal function]: Engined\Rpc\UserMgmt->importUsers(Array, Array)
    #7 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
    #8 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('importUsers', Array, Array)
    #9 /usr/sbin/omv-engined(537): OMV\Rpc\Rpc::call('UserMgmt', 'importUsers', Array, Array, 1)
    #10 {main}

  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!