Updates Failing

  • When trying to update I get the following errors below. Would love to remove PVE and any ZFS.


    Version 5.6.1-1

    Kernel 5.10.0-0.bp0-3-amd64



    >>> *************** Error ***************

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install libnvpair2linux 2>&1' with exit code '100': E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

    <<< *************************************


    >>> *************** Error ***************

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install libnvpair2linux 2>&1' with exit code '100': E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

    <<< *************************************


    >>> *************** Error ***************

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install libnvpair2linux 2>&1' with exit code '100': E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

    <<< *************************************

  • E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

    Have you tried this?!?----------------------------------------^^^^^^^^^^^^^^^^^^

  • yes still getting error messages, I am trying (sorry new here) to figure out how to get all the zfs stuff removed. I wouldnt mind getting rid of the pve since I dont need it anymore.



    The following packages have unmet dependencies:

    libnvpair3linux : Breaks: libnvpair2linux but 2.0.3-pve1 is to be installed

    libuutil3linux : Breaks: libuutil2linux but 2.0.3-pve1 is to be installed

    libzfs4linux : Breaks: libzfs3linux but 2.0.3-pve1 is to be installed

    libzpool4linux : Breaks: libzpool3linux but 2.0.3-pve1 is to be installed

    E: Unable to correct problems, you have held broken packages.

    <<< *************************************

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!