Intel ethernet controller i225-V (solved)

  • Hello everyone.


    I decided to replace my old Synology NAS DS413 by a NAS DOY with openmediavault.


    I had no previous experience with Linux nor OMV.


    Having 2.5 Gbits ethernet on the new NAS is of a particular importance for me and due to lots of warning concerning the use of Realtek ethernet controllers with OMV, I choose to go for intel controller and bought Mini ITX motherboard with I225-v 2.5 gbits intel controller (the Gygabyte Z490I Aorus Ultra, complete configuration at the end of the post).


    That was … an of unfortunate choice to says the least.


    First, I discovered, too late, that, ironically, this intel ethernet controller was infamous to be faulty designed (many post reports more or less serious issues with this controller on windows and linux).


    Then, updating the controller firmware was a nightmare (I succeeded after many days of searching/trying)


    But above all, I did not succeed to use this I225-V ethernet controler with OMV (openmediavault_5.5.11-amd64).


    During the installation of OMV (using USB flash drive), the installer displays a warning that no ethernet card have been detected, and OMV suggest several ethernet drive to be used, which not includes the one required (Intel IGC apparently), none of the other drive suggested work. My Wi-Fi controller are not either recognized during the installation, but I succeeded to instal OMW, using a cheap USB-100 Mbits ethernet adapter. No problem with OMV and this USB ethernet adapter but OMV cannot used at all the i225-V controller (No IP displayed at the start of OMV, no IP adress with “IP a”, no network connection)

    I first thought that I needed to download and install the IGC driver, but I then found that it seems already installed (at least to my understanding). Indeed, I found the “igc” driver in

    Code
    /lib/modules/5.70-0.bpo.2-amd64/kernel/drivers/net/ethernet/intel/igc

    Then after Kernel update in,

    Code
    /lib/modules/5.10.0-0.bpo.3-amd64/kernel/drivers/net/ethernet/intel/igc

    And below the output of various command I tried to understand the situation :

    lspci -knn

    Code
    04:00.0 Ethernet controller [0200]: Intel Corporation Device [8086:15f3] (rev 01)
    Subsystem: Intel Corporation Device [8086:0000]
    Kernel driver in use: igc
    Kernel modules: igc

    Ip a

    Code
    2: enp4s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether b4:2e:99:f8:cf:35 brd ff:ff:ff:ff:ff:ff

    ethtool enp4s0

    dmesg | grep igc

    Code
    [ 0.921412] igc 0000:04:00.0 (unnamed net_device) (uninitialized): PHC added
    [ 1.085179] igc 0000:04:00.0: 4.000 Gb/s available PCIe bandwidth (5.0 GT/s PCIe x1 link)
    [ 1.085187] igc 0000:04:00.0 eth0: MAC: b4:2e:99:f8:cf:35
    [ 1.087292] igc 0000:04:00.0 enp4s0: renamed from eth0

    lsmod | grep igc

    Code
    igc 131072 0
    ptp 28672 1 igc

    modinfo igc

    So to my understanding the driver seems installed, I225-V ethernet controller is seen, and IGC driver is used (right ?), but impossible to use it. I tried several things including updating the I225-v firmware to version 1.45, reinstalling several time OVM, update kernel from version 5.7.0.0 to version 5.10.0 (using OMV web interface with the USB ethernet adapter), install non free driver (using OMV web interface) , change ethernet cable, remove 2.5 Gibits switch, but never succeeded to use the controller.

    I tried to modify kernel configuration, but could not launch make config (source missing ?)

    The good news is that I tried to install a more recent and complete weekly build of Debian (Debian GNU/Linux testing "Bullseye" - Official Snapshot amd64 BD Binary-1 20210222-03:04), from memory linux kernel 4.19 but not sure) and the intel i225-V controller is automatically recognized and network works very well at 2.5 Gbits.

    So my question (from a OMV/Linux newbie) is whether there is something in OMV (modules, dependencies, kernel configuration…) that I have to add/qcompile/configure to use the Intel i225-v controller, or I better try to install OMV on top of another Debian build ?


    Here my complete configuration

    • Case : Fractal design Node 304
    • Mother board : Mini-ITX Gigabyte Z490i Aorus Ultra
    • CPU : Intel pentium G6400
    • RAM : 2x 8 GB Crucial Ballistix 2666 MHz, DDR4
    • SSD 1 : WD Blue SN550 500 Go M2 NVMe (For OMV and later will be split in several partition, for working files and may be Bcache)
    • SSD 2: Samsung EVO 840 SATA (used to test Debian, Windows 10, later for data)
    • HDD: 3 x 10 TB WD red (for the moment still in the synology NAS=
    • PSU: be quiet! Pure Power 11 300 W
    • Connected to 2.5 Gbits TP-Link switch TL-SG105-M2
  • SF_Com

    Changed the title of the thread from “Intel ethernet controller i225-V” to “Intel ethernet controller i225-V (solved)”.
  • SF_Com

    Added the Label resolved
  • Hi. So does it work with normal OMV 5.10.0 installation? Just need to be chosen as default controller? How does it work, no problems, do you get near 280MB/s with your NAS? How much load does it put on the CPU?


    I have found cheap 2.5G cards with I225-V on aliexpress and thinking about upgrading my NAS to the next level. And also don't want realtek garbage.

  • Sorry for my late answer, I didn’t had a notice from your post (or missed it)


    Here my mixed answer to your questions


    Once you know that you have to go on OMV-firstaid to install the controller, it is easy to install and configure.


    Upgrading the firmware of the internet controller was a nightmare (both on Linux and windows), but it is because my systems were in French localisation, and the developers of the firmware update software screwed up with the localisation (the “.” In the firmware version was read as “,”, and the software could not read the firmware version and refuse to update). You should not have problem using English systems, or if interested I can explain how I finally did it on my French system.


    The NAS is connected to a TP-Link 2.5 Gps switch, with 2 PC with 2.5 Gbps Realtek controller and my 5Gps fibre-optic internet connection.


    In terms of performances

    • For download (From NAS to PC), I always have 285 Mbps (ie 2.3-2.4 Gps) in both SMB and FTP. Which is great.
    • For upload (from PC to NAS, or the Internet to NAS) it is more complex. I have big trouble which I tried to troubleshoot for months. When everything goes well, I have also 285 Mbps (ie 2.3-2.4 Gps), but sometimes after a reboot or wake up, the bandwidth is locked to a random threshold which can go from 1 Mbps to 150 Mbps). It impacts the same way, SMB and FTP. I then have to disconnect and reconnect the Ethernet cable physically, or rerun first aid, or reboot the system, which will reset to bandwidth (if I am luck 285 Mbps if not another random value, and I have to redo the procedure again). It is something linked to the 2.5 Gbps, because PC connected in 1 Gbps always have the circa 120 Mbps expected, even when the 2.5 Gbps PC are stuck to 1 Mbps). I have no idea if it is a software issue with OMV or a hardware issue related to the I225-V controller, or unlikely a problem with the switch (both PC always works at 285 MBps between each other). I am still troubleshooting the issue and want try any configuration before I scream for help on the forum.

    Edit [5-9-2021] to mitigate this issue, I disabled the autoshutdown plugin (fewer sleeps and wake-ups, means less chance to switch to a bad bandwidth state) and when it happens I use ip link set enp4s0 down && ip link set enp4s0 up in SSH to reset the ethernet connection.

    • CPU usage is totally OK, 5 % CPU used during a 285 Mbps transfer via SMB.


    So far, I cannot say that the upload issue is linked or not the Intel I225V controller, but it is unfortunately likely and I cannot advise this controller for the moment.


    Sadly, I pay 200 euros to buy a motherboard specifically with the Intel controller to avoid the issues with the Realtek “garbage” controller. I add so much trouble with the Intel controller so far that I really wish I bought a mother board with Realtek controller.


    I don't know if I would have more or fewer problems with a realtek 2.5G ethernet controller.


    I let you know any progress on my PC to NAS bandwidth issue.

  • Hey, thanks for the update. In the meantime i have bought RTL8125B card... and it works great with my HP T620 machine.


    I have set up the jumbo frame to 9000 to get more speed because it was limited to around 200MB/s with default mtu. Now i have stable 290MB/s with FTP, and after some tweaking, stable 280-290MB/s with SMB. Iperf3 shows 294MB/s both ways.


    I am also having little issues with write speeds on SMB, when i tweaked it to get better read... then write speeds dropped. Its still a matter of tuning but i dont have time to play with it more right now.


    I am using second identical RTL8125B card in my PC, don't bought 2.5G switch yet because these are a bit pricey. 5.10 included kernel drivers worked great "out of the box", the only issue was complete lack of communication trough LAN with my mashine after adding the card. I had to use TV and a keabord to run omv-firstaid to fix things up.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!