VMware ESXi and NFS datastore: error 0x80070057 and VM corrupted after migrate

  • Hi.


    I can create VM on NFS datastore but I have error 0x80070057 at the begin of installation. Same if I try to format disk.


    If I try to migrate VM from internal datastore with VMFS6 to NFS the VM is corrupted. Loop in start. Migration with VMware Converter, simply copy, vmkfstools -i


    I try:


    1) NFS v3 and v4 in ESXi

    2) ESXi 6.7 U3 and 7.0.1 (both HP images)

    3) NFS with XFS and EXT4

    4) Default options and rw,sync,no_root_squash

    5) Permissions on folder are 777 for Owner, Group, Other.


    Thank You.

  • If you are using the 5.10 backports kernel, please try the 5.4 proxmox kernel. I have used it for a long time with VMware and KVM over nfs with no issues.

    omv 5.6.13 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • i have a simmilar problem.

    esxi 6.7 u3

    omv 5.6.4-1

    if i try to start a vm on the nfs datastore, i encounter the same problem. VM does not start, looping.

    i have copied a large file from my windows machine to an smb share hosted by omv and checked the filehash, just to be sure its not an hardware issue.

    the filehashes for a cloned vm fom nvme to nfs are also correct

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!