Issue with SFTP - SSH public key authentication not working properly

  • Hi :)


    In SSH configuration i'm using public key authentication and i've disabled authentication with password.


    I'm also using the SFTP plugin and in there it does not matter if i enable or not the public key authentication, it will always act like it's enabled. So if i login in SFTP with WinSCP it will use my private key also if i disabled public key authentication in SFTP.


    Password authentication instead works fine for SFTP even if it's disabled in SSH configuration.


    I think that the SFTP plugin inherits public key settings from SSH, overwriting anything i select for SFTP. Correct?

  • I think that the SFTP plugin inherits public key settings from SSH, overwriting anything i select for SFTP. Correct?

    Nope. The sftp plugin is completely separate from the ssh plugin. It starts its own server process with separate config file. https://github.com/OpenMediaVa…es/omv_sftp_config.j2#L38


    That said, I screwed up the saltstack code when porting to 4.x and it uses all environment variables ignoring some of the settings from the web interface. I never noticed (I do use the plugin) because I never disable public key auth. So, don't look at settings in ssh and think they affect the sftp plugin. I will have to fix it.

    omv 5.6.5 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Nope. The sftp plugin is completely separate from the ssh plugin. It starts its own server process with separate config file. https://github.com/OpenMediaVa…es/omv_sftp_config.j2#L38


    That said, I screwed up the saltstack code when porting to 4.x and it uses all environment variables ignoring some of the settings from the web interface. I never noticed (I do use the plugin) because I never disable public key auth. So, don't look at settings in ssh and think they affect the sftp plugin. I will have to fix it.

    Oh i see, thank you for the prompt response!


    Will keep the thread unsolved in the meantime.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!