Cloud commander deploying issue

  • Hey all. I keep getting:

    [1A[2K Starting cloudcommander_web_1 ... [31merror[0m [1B ERROR: for cloudcommander_web_1 Cannot start service web: OCI runtime create failed: container_linux.go:349: starting container process caused "exec: \"/usr/src/app/bin/cloudcmd.js\": stat /usr/src/app/bin/cloudcmd.js: no such file or directory": unknown ERROR: for web Cannot start service web: OCI runtime create failed: container_linux.go:349: starting container process caused "exec: \"/usr/src/app/bin/cloudcmd.js\": stat /usr/src/app/bin/cloudcmd.js: no such file or directory": unknown Encountered errors while bringing up the project..


    I used this video:

    Can anyone help?

  • On what system do you want to install this?


    And how does your compose file look like?

    Hewlett-Packard HP t630 (AMD Embedded G-Series GX-420GI | QuadCore | 8GB)
    omv 5.6.6-2 (Usul) | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6

  • omv 5.


    The file looks like:


    Code
    version: '2'
    services: web: ports: - 8000:8000 volumes: - ~:/root - /:/mnt/fs image: coderaiser/cloudcmd

    Can you deploy a stack in portainer with this file and test it

    Hewlett-Packard HP t630 (AMD Embedded G-Series GX-420GI | QuadCore | 8GB)
    omv 5.6.6-2 (Usul) | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6

  • Didnt work.

    Code
    Removing cloudcommander Recreating 5356fd797a7a_cloudcommander ... [1A[2K Recreating 5356fd797a7a_cloudcommander ... [31merror[0m [1B ERROR: for 5356fd797a7a_cloudcommander Cannot start service cloudcmd: OCI runtime create failed: container_linux.go:349: starting container process caused "exec: \"/usr/src/app/bin/cloudcmd.js\": stat /usr/src/app/bin/cloudcmd.js: no such file or directory": unknown ERROR: for cloudcmd Cannot start service cloudcmd: OCI runtime create failed: container_linux.go:349: starting container process caused "exec: \"/usr/src/app/bin/cloudcmd.js\": stat /usr/src/app/bin/cloudcmd.js: no such file or directory": unknown Encountered errors while bringing up the project.


    If you highlight the above you will see the error I get. Not sure why it pasted that way.

    Edited once, last by macom: Fixed the invisible text. ().

  • Port 8000 will conflict with portainer agent.

    Change it to something else

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!