Cloned disk doesn't boot up

  • Motherboard: Gigabyte GA-B85M HD3G
    CPU: i5
    OpenMediaVault 5.6.3-1 in UEFI mode.

    I followed Techno dad life to clone omv system disk, sudo dd if=/dev/sdf of=/dev/sde. Boot from the cloned disk, got error:
    directory is encrypted,
    entering rescue mode.

    Did I do something wrong? How to make a cloned disk bootable?

  • I don’t know what you did but this link shows you how to dd from Mac, Linux, or Windows. (It’s not just for Rpi’s.)

    Works for me. Make sure your backup media is good and test it when you finish to make sure it actually works.

    Easy data backup: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    OMV 5 (current) - Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, Wetty, & Heimdall - NanoPi M4 (v.1): backups using Rsync and Rsnapshot - Odroid XU4 (Using DietPi): PiHole - hc2, xu4, Pi 3B+, Odroid H2, and VirtualBox: Testing and playing - Mac user converting to Linux, Debian 10 KDE.

  • I'm having a similar issue as OP.

    Been converting OS drives from other computers using a docking station (P2V) with

    sudo qemu-img convert -p -O qcow2 /dev/sdb '/mnt/OMV/nfs share/imagename.qcow2'

    This has worked great for legacy BIOS systems, 3 done so far.

    But now I'm having problems with a UEFI system drive, LinuxMint 18.3 installed on drive, partition 1 EFI boot, partition OS, partition 3 swap.

    Will only boot to UEFI shell.

    I can attach the imagename.qcow2 image to another vm and read the partitions contents.

    So it is not corrupt.

    No partitions mounted at conversion time (worked well for legacy conversion, no accidental reads or writes).

    Using OMV KVM plugin (by ryecoaaron ) to configure and run vm's.

    Question: Is there anything else / special I can set in the KVM plugin set up?

    I've tried Chipset i440FX & Q35, UEFI On & Off, Storage Volume Bus virtio & sata

    Edited 4 times, last by RonO: more tests done ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!