USB Install on ASUS P5KPL- can’t boot from USB

  • Hello,


    I‘m trying to install OMV from a bootable USB to an older machine with an ASUS P5KPL main board.


    The image was downloaded (5.1.1),

    A stick was formatted to vfat,

    I created a bootable USB stick (using the handy function of the context menu on Linux Mint),

    tested the stick- it boots on other machines (Compaq Presario 6000 e.g.),

    So the bootable image is ok.


    But it won’t boot on this ASUS machine!


    Went into the bios:

    Can set boot order and selected USB as 1st boot option.

    The machine does still not boot into the setup menu of OMV, just get a black screen.

    When I boot the ASUS machine (there’s a Mint 17 on it at the moment), it goes straight into the existing OS and the USB is mounted and appears innocently as a /media drive!


    Not sure where to go from here. Am I right in targeting the main board for this?

    It all hangs on this machine not wanting to boot from USB, slightly frustrated!

  • NAS-i-Goreng

    Changed the title of the thread from “USB Install on ASUS P5KPL” to “USB Install on ASUS P5KPL- can’t boot from USB”.
  • You can try if you have more luck with installing Debian.

    If that works, you can install OMV on top.


    https://wiki.omv-extras.org/do…lling_omv5_i386_32_bit_pc


    Or install OMV on another machine and then put the hdd/ssd with OMV installed in the target device. Then configure the network interface using omv-firstaid

  • Well,


    I wanted to get away from using any full Linux distro for just a file server.

    OMV seemed just right, also as I can allocate space for other users more easily.


    And this is the old machine I got, wanted to make use of it.


    Ok, I can try and burn a CD but then again- if it recognises the USB stick, it might not install from CD either.


    Just wonder why and whether anyone else had this before as well.

  • I still had an image of Bodhi Linux around and created a bootable stick with that.

    The machine consistently ignores the USB stick.


    So whether it’s OMV or Debian doesn’t seem to matter- now I do blame ASUS...


    Done have a 2nd machine at hand where i can just swap the HDD.

  • I had the same Problem on an Asus P5K. If you have a floppy drive you can use this. It worked for me. Or you can just try booting from a DVD, that should work. Booting from USB was pretty new for consumer platforms back then and the implementations were not very reliable in the beginning.

  • I'd agree Knuschberkeks . do you have an optical drive? Just burn the image to a cd or dvd, boot it and install per instructions

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • You may be creating a UEFI (GPT partition scheme) bootable USB drive, which an older computer that only has a BIOS (and expects an MS-DOS partition scheme) won't understand.

    You should be able to flash the .iso image directly to your USB drive using something like balenaEtcher, without needing to format or otherwise prep it first.

  • Ok, just to give some feedback:

    This main board definitely did not want to do a USB install.


    I burnt the image on a CD and it all worked well.


    I‘m now working myself into the details of OMV.

  • macom

    Added the Label OMV 5.x
  • macom

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!