Putting the webui behind a base url

  • Hi folks,


    I think this might be more of an nginx question rather than an OMV one, but I figured I'd ask here anyway.


    I have an nginx instance on another machine, which is basically the gateway to my network.

    All externally facing services pass through that.

    I want to add OMV's webui to that list.


    So I added this to the gateway


    Code
    location /foo {
    proxy_pass http://192.168.x.y:80/; #OMV server IP
    }



    As expected, this leads to a myriad of errors like:


    Code
    The resource from “https://redacted/extjs6/classic/theme-triton/resources/theme-triton-all.css” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff).
    The resource from “https://redacted/css/theme-all.min.css” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff).
    The resource from “https://redacted/js/js-overrides.js” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff).



    So my question is, what do I need to do to get OMV to accept its new base url of /foo so that it asks for https://redacted/foo/js/js-overrides.js instead?


    Is this just an nginx configuration issue? Do I need to config something in OMV itself?


    Or I am going the wrong way about with this?


    Is there a better way to achieve what I want?


    I am very much a noob when it comes to nginx and the like.


    Thanks!

  • crashtest

    Approved the thread.
  • xnick

    Changed the title of the thread from “Putting the webui behind a url base” to “Putting the webui behind a base url”.
  • KM0201

    Approved the thread.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!