Apt update error. Repository not signed. 403 Forbidden

  • This morning I logged in to update my server and was met with the following. I have gone through this forum and google quite extensively but cannot find an answer. I tried apt clean, changing DNS and some commands listed in other threads to name a few. I never use the GUI for updating as I usually get at least 1 error. Usually everything goes well. I would rather not reinstall if I don't have to (which has been a common answer to a lot of issues). Any help would be appreciated.


    Thanks.


    Just the error,


    and full output.


  • You won't have to re-install for a minor apt repo issue. I'm not sure how you still have bintray repos and the new github repos (omv-extras repos moving to github).


    sudo rm /etc/apt/sources.list.d/omvextras.list

    sudo omv-salt deploy run omvextras

    omv 5.6.5 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Thank you so much. I just updated both of my servers and they work now. For some reason I had to cd into the sources.list.d folder and rm from there as it didn't work at first.


    I have to admit I think I came across this solution but it didn't work so I moved on. In my frustration I didn't bother to check that the file was removed and kept moving.


    Thank you.

  • Need your help to update OMV4 with omv-extra.org

    omv4 didn't have omv-salt to re-deploy omv-extra.

    omv4 needs a lot more fixing which is why I didn't "fix" it (it is EOL'd). I recommend just uninstalling omv-extras (or at least remove /etc/apt/source.list.d/omv-extra-org.list) if you don't want to upgrade to a supported OMV release.

    omv 5.6.5 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • omv4 needs a lot more fixing which is why I didn't "fix" it (it is EOL'd). I recommend just uninstalling omv-extras (or at least remove /etc/apt/source.list.d/omv-extra-org.list) if you don't want to upgrade to a supported OMV release.

    Got it

    Thanks a lot

    let me plan to upgrade to omv5

    I used zfs on it

    i will remove source.lists.d/omvextraorg.list first

  • I used zfs on it

    Removing omv-extras doesn't remove the zfs plugin. It would just prevent any updates but there will be no 4.x updates.

    omv 5.6.5 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.1
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!