Cannot add shared folder

  • Hello,


    I added a user, group "users", mounted a volume and wanted to allocate a space on this volume to this user (under access control -> shared folders).


    It returns the error message: "Failed to set file group to 'users' for '/srv/dev-disk-by-label-USB1/John/"


    I had similar trouble mounting the USB stick which also returned an error message (forgot what it was) but I went via the terminal "mount" command an et voila the USB is mounted!


    Is this a bug?

  • Ok, so this one I can now answer myself after quite some time invested.

    But the reason was „simple“: A vFAT formatted USB stick doesn’t listen to any nonUnix permission settings.

    Hence it is always mounted as „root“.

    Only way out is to format it in a different format.


    It does leave the problem of: How do you interconnect with Windows-created USB sticks as a non-root user?

    But that’s a general Linux, not an OMV issue...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!