GUI over HTTPS with hiccups & errors

  • Hi all,


    I can’t get to the GUI over HTTPS.

    Tried some browsers and even with add-ons (https-everywhere etc.) they won’t create a secure connection.

    OMV doesn’t seem to provide it.


    What I did:

    Activated: „enable SSL/TLS“ and it requires to name a certificate so...

    Created a SSL certificate under system->certificates->SSL;

    Back to system->general settings->secure connection: named the just created certificate, save, apply.

    Left out „force SSL/TLS“ because I assume that this locked me out last time and I went for a re-install (which was faster);


    So tried port 443 (left unchanged) and don’t get a connection. It jumps back to HTTP on port 80

    Happy to try to activate the force option again but then... where can I find the config file to reverse this via command line?


    nmap returns (amongst others):

    ...

    443/tcp open https

    ...


    Did I miss something?

  • Update on this:


    Yes I can get the GUI via https now. But with two "hiccups":


    1. One can still use https on port 80 for a plain user, not for admin login.

    2. I cannot force a secure connection. If I activate this option, I get a long error message. The one that I filtered out were the ones listed below.


    Could anyone interpret these perhaps?


    ID: prereq_nginx_certificates

    Function: salt.state

    Result: False

    Comment: Run failed on minions: debian

    Started: 20:52:33.401008

    Duration: 2357.754 ms

    Changes:


    ID: remove_ssl_certificates_key

    Function: module.run

    Name: file.find

    Result: False

    Comment: No function provided.

    Started: 20:52:34.036121

    Duration: 1.454 ms

    Changes:


    ID: monitor_nginx_service

    Function: module.run

    Name: monit.monitor

    Result: False

    Comment: No function provided.

    Started: 20:52:37.755985

    Duration: 1.652 ms

    Changes:

  • NAS-i-Goreng

    Changed the title of the thread from “Can“t get GUI over HTTPS” to “GUI over HTTPS with hiccups & errors”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!