Folders in /sharedfolders appear empty to other processes

  • I'm not sure if the subject title is accurate, but that's what I understand.

    I have OMV running on my RPi with an external USB HDD connected to it for data storage. As far as accessing files via SMB and FTP goes, all works great.

    But for some reason, if I connect to the server's shell via SSH, all the folders located in "/sharedfolders" appear empty, even as root (Syncthing installed on this server also cannot see contents of these directories). According to ACL, everyone should have access to at least this specific directory, right?

    Screenshot attached. I'm confused, what's going on here?

    Server: ODROID-HC4 + 2x 8TB Seagate IronWolf HDD + OMV

  • /sharedfolders is no longer populated by default. If you need access to the shares use the full Absolute path.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • /sharedfolders is no longer populated by default. If you need access to the shares use the full Absolute path.

    I see.

    I found my files in "/srv/dev-disk-by-label-SEAGATE/", I'm guessing that's the correct directory now?

    Server: ODROID-HC4 + 2x 8TB Seagate IronWolf HDD + OMV

  • You can look in the OMV GUI | Access Rights Management | Shared Folders and click on the Absolute Path tab. If that tab is not visible you can enable it by clicking on any other tab's down arrow, select Columns and put a check mark on Absolute Path.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

  • You can look in the OMV GUI | Access Rights Management | Shared Folders and click on the Absolute Path tab. If that tab is not visible you can enable it by clicking on any other tab's down arrow, select Columns and put a check mark on Absolute Path.

    That column clears up everything, thank you :)

    Server: ODROID-HC4 + 2x 8TB Seagate IronWolf HDD + OMV

  • /sharedfolders is no longer populated by default. If you need access to the shares use the full Absolute path.

    Just discovered this - from when is this changed,, and why?


    You say "by default" - is it possible to "turn it on" again? (Through GUI)


    Sorry for my ignorance:rolleyes:

  • This change came with openmediavault (5.3.3-1) See the changelog for details:


    https://github.com/openmediava…diavault/debian/changelog


    To revert to the previous behavior, in a root shell:


    Add OMV_SHAREDFOLDERS_DIR_ENABLED="YES" setting to /etc/default/openmediavault and then run:

    omv-salt stage run prepare

    omv-salt deploy run systemd

    reboot

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 6.x on headless Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

    Edited once, last by gderf ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!