Boot takes forever to start

  • Hi,

    I have had the problem that OMV takes forever to start. Recently I upgraded from OMV 4 to 5 in the hope that it would get better. Unfortunately it didn't help. Now my logs are also regularly full, so I can no longer log in to the GUI, but have to clean up via ssh first.

    Does anyone have an idea how I can get to a normal boot behaviour? I had already discovered an article that pointed to a problem with Intel graphics drivers. However, I do not have a CPU unit with a graphics chip installed. I have a small Radeon in use for this.

    Since the upgrade, I also have the problem that it seems to try to use the wrong network adapter from time to time. (I have two connections on the mainboard.) At least the server does not show up at all and only comes up after another reboot. Of course, the waiting time described above is also present.

    Thanks in advance!

  • hmm.

    I would start by reading those logs you're just deleting. Maybe try clean installing 5 vs an upgrade . Since you were apparently having issue with 4... I rarely upgrade.. but as a rule I never upgrade a machine that is having issues, unless it is documented the upgrade solves those issues... As it rarely will just solve random problems and the issues will simply be present in the upgrade.

    Air Conditioners are a lot like PC's... They work great until you open Windows.

  • Now my logs are also regularly full,

    Did you check what is written in the logs? Might help to fix it.

    OMV takes forever to start.

    These commands might give you a hint what is taking long:

    systemd-analyze blame


    systemd-analyze critical-chain

    Read more at:…/man/systemd-analyze.html

  • I tried to get some infos out of the logs.

    I noticed some problems in an vpn script, but I solved this. Then I found some issues in the network and with clamav but have no clue how to deal with it.

    I tried your commands. Network is the most problematic ONE. plex media service is an docker container that cannot start normal itself. Because the related disc is encrypted. Maybe I can drop that from autostart?

    6min 30.331s networking.service

    5.240s plexmediaserver.service

    3.320s openmediavault-issue.service

    1.475s ifupdown-pre.service

    1.331s docker.service

    660ms apt-daily.service

    535ms certbot.service

    526ms apt-daily-upgrade.service

    485ms postfix@-.service

    443ms logrotate.service

    430ms openmediavault-beep-up.service

    201ms containerd.service

    157ms dev-nvme0n1p1.device

    147ms phpsessionclean.service

    124ms loadcpufreq.service

    119ms smbd.service

    117ms nmbd.service

    99ms systemd-journal-flush.service

    90ms nginx.service

    84ms quotarpc.service

    75ms chrony.service

    75ms lvm2-monitor.service

    74ms php7.0-fpm.service


    ...skipping 1 line

    62ms rrdcached.service

    61ms systemd-udev-trigger.service

    50ms systemd-logind.service

    50ms systemd-journald.service

    50ms avahi-daemon.service

    49ms wpa_supplicant.service

    49ms clamav-daemon.service

    48ms systemd-fsck@dev-disk-by\x2did-nvme\x2dSamsung_SSD_960_EVO_250G


    42ms dev-disk-by\x2duuid-2bbdc370\x2dbfb5\x2d442d\x2d9826\x2d37b4d28


    42ms run-rpc_pipefs.mount

    41ms ssh.service

    38ms openvpn@C_Rotterdam_VPN.service

    34ms systemd-tmpfiles-clean.service

    27ms cpufrequtils.service

    26ms collectd.service

    23ms systemd-user-sessions.service

    22ms quotaon.service

    20ms quota.service

    15ms watchdog.service

    14ms systemd-udevd.service

    13ms systemd-quotacheck.service


    ...skipping 1 line

    12ms openmediavault-engined.service

    10ms keyboard-setup.service

    10ms systemd-tmpfiles-setup.service

    10ms dev-hugepages.mount

    9ms sys-kernel-debug.mount

    9ms systemd-sysusers.service

    9ms systemd-sysctl.service

    9ms systemd-remount-fs.service

    9ms systemd-tmpfiles-setup-dev.service

    7ms dev-mqueue.mount

    6ms kmod-static-nodes.service

    6ms systemd-random-seed.service

    6ms blk-availability.service

    5ms srv-dev\x2ddisk\x2dby\x2did\x2dnvme\x2dSamsung_SSD_960_EVO_250G


    5ms systemd-update-utmp.service

    5ms systemd-modules-load.service

    5ms systemd-update-utmp-runlevel.service

    4ms console-setup.service

    4ms rpcbind.service

    4ms openmediavault-cleanup-monit.service

    4ms sharedfolders-Quarant\xc3\xa4ne.mount

    3ms var-lib-docker-openmediavault.mount


    3ms openmediavault-cleanup-php.service

    2ms nfs-config.service

    2ms rsyslog.service

    2ms sharedfolders-DockerM.2.mount

    1ms tmp.mount

    1ms nfs-blkmap.service

    1ms postfix.service

    972us docker.socket

  • I want to avoid a fresh install. To much initial pain in the ass. :D

    Mai 15 09:20:10 C. local systemd[1]: Starting Raise network interfaces...

    Mai 15 09:20:10 C.local ifup[748]: ifup: waiting for lock on /run/network


    Mai 15 09:25:10 C.local systemd[1]:

    rvice: Start operation timed out. Terminating.

    Mai 15 09:25:10 C.local ifup[748]: Got signal Terminated, terminating...

    Mai 15 09:26:40 C systemd[1]:

    rvice: State 'stop-sigterm' timed out. Killing.

    Mai 15 09:26:40 C.local systemd[1]:

    rvice: Killing process 748 (ifup) with signal SIGKILL.

    Mai 15 09:26:40 C.local systemd[1]:

    rvice: Main process exited, code=killed, status=9/KILL

    Mai 15 09:26:40 C.local systemd[1]:

    rvice: Failed with result 'timeout'.

    Mai 15 09:26:40 C.local systemd[1]: Failed to sta

    rt Raise network interfaces

  • Then you have to accept dealing with the problem or spend your life tracking a fix. I honestly can't understand how people think reinstalling is a pain in the ass. I can have a blank disk to all my services up and running in probably an hour tops (especially if you're mostly using docker, etc.)

    Air Conditioners are a lot like PC's... They work great until you open Windows.

  • I want to avoid a fresh install. To much initial pain in the ass. :D

    Looks like you’ve got one now. :D

    Simple and sure backup and restore: In a Scheduled Job: rsync -av --delete /srv/dev-disk-by-label-SOURCE/ /srv/dev-disk-by-label-DESTINATION/ (HT: Getting Started with OMV5)
    Server Software: OMV 5 (current) - My Main Server: Thinkserver TS140, Nextcloud, Plex, Airsonic, Navidrome, Ubooquity, Digikam, & Heimdall - My Backup Machine: NanoPi M4 (v.1), Pi-Hole - Odroid XU4 (Using DietPi) - Testing/Playing: hc2, xu4, Pi 3B+, Odroid H2. Mac user converting to Linux, Debian 10 KDE.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!