Problem booting after install to USB

  • Hi there

    OMV newbie here (and a not very techie one at that) so apologies in advance if I'm being overly detailed, not explaining myself very clearly or posting to completely the wrong place - especially as I'm not sure if this is an OMV issue per se.


    I've just bought an HP N40L Microserver on eBay with a view to setting it up with OMV, installing the OS onto a USB stick plugged into the computer's internal USB port (since I understand this works OK with the appropriate plugin).


    I have now successfully installed OMV twice - sort of - but...


    On my first attempt, I installed from a USB key plugged into the front of the machine, to a brand new 32GB Kingston DataTraveller Exodia memory stick plugged into the internal USB port on the motherboard. The installation appeared to go fine and once it completed, I removed the installation USB as instructed and rebooted the machine just fine. I then carried on with my installation settings and all seemed fine and dandy. However, having got everything up and running with the machine in the temporary physical location where I had set it up (so I could plug it into my screen for the initial setup), I then tried to move it to its permanent location. Finding that I could not log in remotely, I moved it back to the screen and rebooted, only to find that it was looping the following error message:


    Boot failed, continue to look for boot media

    Wait for input.....


    Boot failed, continue to look for boot media

    Wait for input.....



    After much head scratching and limited success looking for answers on t'interweb, I concluded that the issue must be that I had installed from a USB stick to a USB stick: I found a post which vaguely described a similar issue someone was having and suggested that installing from CD to USB should fix the problem. So I burned the installation ISO to a CD and set about reinstalling from scratch (albeit using an external DVD drive connected by USB...). Once again, the installation appeared to go swimmingly, successfully rebooting for the first time after I removed the installation media, but I am again finding that any further attempts to power down and restart come up with the same error message.


    Finally, after further messing about experimenting changing various settings, I have worked out (almost by accident) that if I boot up with the installation CD plugged in but, rather than sticking with the first option on the Boot Menu - Install, I select the second option - Install (serial console) and hit enter, it seems at first as if nothing happens (the screen just goes black) but if I then unplug the installation CD and press Ctrl+Alt+Del to reboot the machine again, it then boots straight into my OMV installation and I can log in remotely without any issue.


    It seems to me, therefore, that technically the installation to USB has worked; however, it is a real pain (not to say not really very practical if I want to use this as a headless machine, which I do) that I have to go through the whole start-off-with-the-installation-CD-in-place rigmarole.


    I have to believe (or at least really, really want to believe) that something can be done so that it boots straight from USB without having to plug the CD first.


    Just to clarify, in the BIOS menu the option to boot from USB is set to high priority. Also, in case it matters I have noticed that if I boot from cold (i.e. not by going via the OMV startup CD), after the initial ProLiant MicroServer splash screen, the computer spends an age (around 120 seconds) showing the message "initializing USB controllers"; however, after rebooting from the OMV Install (serial console) option, it only spends a few seconds on "initializing USB controllers" before booting up OK into OMV.


    Any assistance on resolving this would be much appreciated; however, please understand that all this is way above my pay grade (AKA my level of technical competence!) and so any suggested fix needs to be explained to me in detail, as though I were a five year old. In other words, "just run XYZ..." probably won't help as I don't know how to run anything on a machine which won't boot!


    Many thanks in advance for taking the trouble to read this.

  • I have an N54L which boots from the internal USB, initially this was installed via CD using the ISO and it just works.


    But taking your first attempt, this as you said worked, then didn't work when you moved it, two things would have happened;

    1) The IP address would have probably changed

    2) The boot loader (grub) was not applied to the USB that OMV was going to run from, this can happen when installing from a USB drive, this would give the error you have seen. This is fixable.


    Second attempt, this is weird as installing from CD using the ISO (even if the CD is a USB drive) it should just work and boot from the USB drive OMV is installed on.


    As this works albeit with the re use of the CD and you can access OMV's GUI, enable ssh and set the Permit root login, ssh into OMV from your workstation or laptop and run update-grub. Shutdown OMV, this will disconnect the ssh session and shutdown the server, disconnect the USB CD and switch on. This is now the part where OMV will boot up or it gets stuck looking for the boot media.


    You might want to look at this there are some links in post 3, I have completed this on my N54L

    Raid is not a backup! Would you go skydiving without a parachute?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!