How update kernel?

  • Kernel 5.8.0 is currently installed, how to update it?

    What should be the repositories?

    Now:

    Code
    deb http://deb.debian.org/debian/ buster main
    deb-src http://deb.debian.org/debian/ buster main
    deb http://deb.debian.org/debian/ buster-updates main contrib non-free
    deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free
  • or if backports is disabled. The repo tab on omv-extras will tell you if it is disabled.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • If you removed the non-Proxmox kernels, then you should be using the Proxmox kernel. Depending on when you installed it, that will be 5.4 or 5.11. As long as you are booting one of those kernels, it really doesn't matter if the 5.8 kernel is on your system.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • uname -a

    Code
    Linux openmediavault 5.8.0-0.bpo.2-amd64 #1 SMP Debian 5.8.10-1~bpo10+1 (2020-09-26) x86_64 GNU/Linux

    apt search linux-image

    What's the last stable kernel to install? Because it seems to me that my kernel is not updating

  • What's the last stable kernel to install?

    linux-image-amd64. If you don't have that package (which is a meta package pointing to the latest), then you won't get newer kernels.


    sudo apt-get install linux-image-amd64

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Can you help me further, do I have the correct repositories?

    /etc/apt/sources.list

    /etc/apt/sources.list.d/openmediavault-os-security.list

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!