Web Gui is not reachabel

  • Ich habe ein Problem.

    Nachdem ich heute ein kleines Problem hatte, wurden ein paar Dateien von OVM gelöscht. - Denke ich zumindest -. Alles funktioniert auch noch ( Das NAS ), aber das Web-GUI funktioniert nicht mehr :(


    502 Bad Gateway

    nginx


    Ich habe schon versucht Openmedivault neu zu installieren via apt-get install --reinstall openmediavault.

    PHP: 8.0.5

    Apache2 Server am laufen (neu)

    Rasp 3


    Das ist der Fehler-Code in der openmediavault-webgui_error.log:

    Siehe Unten:

    //////////////////////////////////////////////////////////////////////////////


    I have a problem.


    After I had a little problem today, a few files were deleted by OVM. - At least I think so -. Everything still works too ( The NAS ), but the web GUI doesn't work anymore :(



    502 Bad Gateway

    nginx



    I already tried to reinstall openmedivault via apt-get install --reinstall openmediavault.


    PHP: 8.0.5

    Apache2 server running (new)

    Rasp 3


    This is the error code in the openmediavault-webgui_error.log:


    See Below:

    2021/05/21 13:37:48 [crit] 4697#4697: *1 connect() to unix:/run/php/php7.3-fpm-openmediavault-webgui.sock failed (2: No such file or directory) while connecting to upstream, client: ::ffff:192.168.178.100, server: openmediavault-webgui, request: "GE$

  • PHP: 8.0.5

    Apache2 server running (new)

    Are you trolling us? First OMV uses nginx. Second, OMV 5.x requires php 7.3. Finally, you can only get php 8.0 from debian experimental and OMV 5.x requires Debian 10.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • Yeah, I know. But I have read in many forums that it could have something to do with the Apache2 server, because I have set it up today I wrote it down. Because of that, I have then also installed php8.0. Since then nothing works.
    I only get "502 Bad Gateway" when I call the domain of OMV

  • Since then nothing works.

    Shocking. You install things that are not right for OMV and it breaks OMV. If you know OMV requires nginx and php 7.3, why would you install apache and php 8.0? Follow raulfg3's suggestion and maybe it will work if you stop installing things that break OMV. If you need apache, either use docker or run it in a VM.

    omv 6.0.5-2 Shaitan | 64 bit | 5.13 proxmox kernel | omvextrasorg 6.0.4 | kvm plugin 6.0
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!