[SOLVED] "Too many redirects" when DNS Proxy is enabled (CloudFlare)

  • Hi, I noticed something strange...

    When I enable Proxy on CloudFlare DNS configuration, my services are not found with a "Too many redirects" error message.

    Disabling Proxy from CloudFlare dashboard, they back active...


    This is the Duplicati DNS configuration on CloudFlare, but duplicati.myurl.com it does not work:



    This one, instead, it works:

  • mbinax

    Changed the title of the thread from “"Too many redirects" when proxy enabled on CloudFlare” to “"Too many redirects" when DNS Proxy is enabled (CloudFlare)”.
  • I had a lot of problems with cloudflare (mostly related to my services just randomly disconnecting).. Not really sure why. I'd used it before w/o issue.


    Eventually just dropped it and just use swag/dns... works fine and everything seems secure.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • Sorry, misspoke. I was thinking some other things I'd tried to get around this. I was getting similar issues as you, to many redirects or as I said, just random disconnects all the time.


    Here's what finally worked (you'll have to change your DNS servers off the cloudflare ones and back to the ones your provider gives you)

    Air Conditioners are a lot like PC's... They work great until you open Windows.


    Edited once, last by KM0201 ().

  • Mmmhhhhh...

    Swag compose file is similar:


    So, I suppose you're right about Cloudflare issues...

    :-(

  • Mmmhhhhh...

    Swag compose file is similar:


    So, I suppose you're right about Cloudflare issues...

    :-(

    I don't claim to be an expert on this subject, I just had a lot of issues w/ cloudflare (may well have been I was setting it up wrong), and when I went to http validation.. no problem at all.


    Also looking at your ports, I'm assuming you've moved OMV off port 80? Otherwise, that is going to conflict.

    Air Conditioners are a lot like PC's... They work great until you open Windows.


  • It's the easiest possible (the standard one...).

    I'm using netdata.mydns.it hostname

  • This is the Duplicati DNS configuration on CloudFlare, but duplicati.myurl.com it does not work:


    I'm using netdata.mydns.it hostname

    Ok, first you say "duplicati...." doesn't work. Then you speak about "netdata...."

    What doesn't work, after all????


    Do you even have any access to any service via SWAG? In which context is the SWAG created? With what services? And are they accessible?

    What OS are you running?


    For you to reach the subdomains via SWAG, they have to be either on the same YAML (stack in Portainer although I had issues and only do it via CLI) or create a network and add ALL the services to that network.

    I saw a good explanation by Morlan how to do this in here:

    RE: SWAG, Let’s Encrypt and Web GUI

  • Ok, first you say "duplicati...." doesn't work. Then you speak about "netdata...."

    What doesn't work, after all????

    You're right, of course: I mean NETDATA.


    Yes, I have access to any other service via SWAG, configured in the same way.

    They are: duplicati, nextcloud, heimdall, tautulli, redis, ombi, mariadb and qbittorrent.


    But... it's solved.

    Simply, I forgot to link the same "swag_network" in the netdata YML, and I was checking it in the Duplicati YML :S

    Code
    ...
    networks:
    default:
    external: true
    name: swag_default
  • mbinax

    Added the Label resolved
  • mbinax

    Changed the title of the thread from “"Too many redirects" when DNS Proxy is enabled (CloudFlare)” to “[SOLVED] "Too many redirects" when DNS Proxy is enabled (CloudFlare)”.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!