libpam-modules-bin (= 1.3.1-5) but 1.4.0-7 is installed

  • Hello, first time posting here, as my experience with OMV is quite recent but has been mostly good so far. Here is what happened:


    1. I have an OMV 5.6.10-1 box set up with an EXT4 RAID0 with docker handling plex, radarr, sonarr, etc., which have had their issues but I managed to sorta fix that

    2. I also have a quadro m2000 in there that I want to use for plex transcoding. I initially followed this thread: How to setup Nvidia in Plex docker for hardware transcoding? and it seemed to be working but I was getting very bad performance - only around 15% GPU utilisation when transcoding 4k HEVC to 1080p. (opposed to 60-80% when I was testing the card under windows with the same file)

    3. I thought it was something with the drivers and the cuda/nvenc versions so I dug in to find alternative methods, and came across this: [HowTo] Nvidia hardware transcoding on OMV 5 in a Plex docker container - I can see the person that created this guide is marked as "Beginner" but the guide is very well laid out and also corresponds to other forums where people are saying the correct way to do it is through Debian Sid and backport drivers, not through the official nvidia drivers as instructed in the first thread.

    4. So I added Sid to sources and followed the steps, making sure to clean the previous installation first (apt-get purge *nvidia*)

    5. The first try I got the driver installing and was getting the prompts as expected. Before the driver started installing I got a prompt saying there are modules that are currently active and need to be suspended in order to get the installation going, so I selected yes. I think that was my first mistake as during the driver install I lost SSH access and couldn't get it to work again until I went in the OMV GUI and disabled/re-enabled SSH.

    6. After the initial fail, I did a purge again and repeated the steps, but this time there were no prompts and no messages - it seemed the driver installed without an issue, but when I tried nvidia-smi I got "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running." and no matter what I tried, it was just not picking it up. I also noticed the second time the driver version was older than the first, not sure exactly but was something like latest 460.84 the first time vs 430.xx on the consecutive tries.

    7. I repeated 6) couple more times with the same result and was almost hopeless I'll get it to work until I found on multiple threads an apt upgrade might help so did that. There were quite a few updates a lot of which installed with no issue until it reached the libpam-modules. It failed and suggested apt --fix-broken install which resulted in a full-screen prompt saying pam_tally and pam_tally2 modules are deprecated in pam 1.4.0-7 and all their instances in the configs have to be replaced with pam_faillock before the upgrade can continue.

    8. I dug in to understand what it will take to do that and if it will break everything, and found this: https://bugs.debian.org/cgi-bi…port.cgi?att=1;bug=982530 - it seemed pretty serious and potentially installation-breaking, so I did not touch any of the files in /etc/pam.d/ (grep-ing showed 4 configs containing the modules)

    9. Instead, I tried to revert what I did - removed Sid from sources and did omv-aptclean as suggested elsewhere. This didn't seem to do much and after restart I'm now only getting the below error - no prompts or messages, just that.

    10. I still have full access to the box and everything seems to be still working (GUI, SSH, containers, etc.), but I cannot install/remove any modules and all apt commands result in the same error below:


    root@HTPC:~# apt --fix-broken install

    Reading package lists... Done

    Building dependency tree... Done

    Reading state information... Done

    Correcting dependencies... failed.

    The following packages have unmet dependencies:

    libpam-modules : PreDepends: libpam-modules-bin (= 1.3.1-5) but 1.4.0-7 is installed

    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

    E: Unable to correct dependencies


    Any suggestions that would not result in a reinstallation of the whole box are greatly appreciated. Thanks!

  • KM0201

    Approved the thread.
  • 8. I dug in to understand what it will take to do that and if it will break everything, and found this: https://bugs.debian.org/cgi-bi…port.cgi?att=1;bug=982530 - it seemed pretty serious and potentially installation-breaking, so I did not touch any of the files in /etc/pam.d/ (grep-ing showed 4 configs containing the modules)

    You are surely using backports (libpam-modules 1.4.0-7 was introduced in Debian 11 and is maybe available via the backports repo) which is strictly forbidden in OMV because of exactly this problem you are now running into. Backports may break existing implementations/workflows through incompatibilities, because of that OMV is only based on the stable branch.

  • KM0201

    Approved the thread.
  • You are surely using backports (libpam-modules 1.4.0-7 was introduced in Debian 11 and is maybe available via the backports repo) which is strictly forbidden in OMV because of exactly this problem you are now running into. Backports may break existing workflows, because of that OMV is only based on the stable branch.

    Thanks for the response, I get that now. Question is, is the install salvageable or I have to start from scratch?


    I saw a suggestion somewhere to use apt-get install openmediavault --reinstall but from the responses it seems this results in even bigger mess...

  • You need to uninstall the libpam-modules 1.4.0-7 package and reinstall the 1.3.1-5 from Debian 10 (Buster).

    If this does not help you should consider to reinstall your system from scratch.

  • You need to uninstall the libpam-modules 1.4.0-7 package and reinstall the 1.3.1-5 from Debian 10 (Buster).

    If this does not help you should consider to reinstall your system from scratch.

    I see, thanks.


    apt remove and apt purge result in the same error above...
    I get this on find:


    root@HTPC:~# sudo apt search libpam-modules

    Sorting... Done

    Full Text Search... Done

    libpam-modules/stable,now 1.3.1-5 amd64 [installed]

    Pluggable Authentication Modules for PAM


    libpam-modules-bin/now 1.4.0-7 amd64 [installed,local]

    Pluggable Authentication Modules for PAM - helper binaries


    Not sure if there is another way to remove them.


    It seems I will be calling the cleaners when quality of life totally breaks.

  • I had this exact same issue, though it was because I didn't read through the whole nvidia install page before I started executing commands. I tried everything I could find to try to resolve the libpam problem but am resorting to a clean install. Not ideal but I've spent enough time struggling to justify the time to reinstall and start the nvidia driver install from scratch.

    Xeon E3-1240v3

    X10SLM+LN4F

    32 GB Ram

    8x4 TB Ironwolf RZ2

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!