Install other version of PHP

  • Hello,

    I'm using OMV5 on which I've installed apache2 & Nextcloud as well.

    Some NC apps require newer version of PHP (OMV5 comes with PHP7.3)


    So short question: Is it possible to install PHP7.4 next to the existing 7.3 so that OMV can still keep using that one?

    Or: will I break things and is it wiser to wait for OMV6?

  • It would be wiser to run apache, nextcloud, and other php versions in a container. You are just asking to break something otherwise.

    omv 5.6.12 usul | 64 bit | 5.11 proxmox kernel | omvextrasorg 5.6.2 | kvm plugin 5.1.6
    omv-extras.org plugins source code and issue tracker - github


    Please read this before posting a question.
    Please don't PM for support... Too many PMs!

  • I've been running Apache + Nextcloud for 3 years now without problems (OMV is using Nginx & I'm running that on a different port).

    For other PHP version: a good idea to run that in a container, running another version may be a bridge too far for OMV to run well :-)


    Thx for advice

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!