Dashboard not accessible from internet when using non default ports

  • Hi:


    If I change the default 80/443 ports to something else like 8080/8443, my OMV5 dashboard won't be available from the internet. All things equal, but with the default ports, the system works great.


    I have done this so far:


    * I have checked the OMV5 documentation to see if there is something special regarding the ports for the Web Administration, but I wasn't able to find something there: https://openmediavault.readthe…n/5.x/various/advset.html

    * I have checked that all those ports are opened o my router and forwarded to my OMV5 box.

    * I have even checked various combinations for the URL, like explicitly writing http / https and :8080 / :8443 on the web browser.

    * To see if this may be related to Cloudflare I have tried to access the dashboard using my public address (My assumption is that in this way I will bypass the restrictions/security from Cloudflare).


    I'm getting a 522 error on the browser (A timeout according to the Cloudflare page that seems to blame my device). I have checked this article to see if there is any restriction of the ports, but it seems to be okay: https://support.cloudflare.com…e-with-Cloudflare-s-proxy


    Could it be something else that I have to do on my OMV5 to make it "listen" to other ports from the WAN? Locally those non-default work ok.


    I appreciate any light on this.


    Thank you!


    Best regards,


    Mauricio

  • KM0201

    Approved the thread.
  • Will your ISP allow transport to port 8080? Many don't as this is a well known (and frequently abused) proxy port.


    Is OMV running on ports 8080 or 8443 or did you leave it as 80 or 443.

    --
    Google is your friend and Bob's your uncle!


    OMV AMD64 5.x on Chenbro NR12000 1U 1x 8m Quad Core E3-1220 3.1GHz 16GB ECC RAM.

    Edited once, last by gderf ().

  • Thank you for your response gderf, what you mention about the ISPs is new information to me that I wasn't aware of.


    Yeah! I've changed the OMV ports according to the router setting. However you made me realize other combinations to try.


    On router, I forwarded 80/443 traffic to 8080/8443 on the OMV. Now it works! If I type https://mysite.com I get the OMV dashboard. Then I would say this is not the OMVs fault (Because I have set a custom port for it, which was my doubt about OMV). This issue must be related to the ISP.


    However, to check that last assumption, I've tried on the router forwarding the ports (supported by Cloudflare for https): 443, 2053, 2083, 2087, 2096, 8443 to the internal 8443 on the OMV5. Of those, only the 443 worked.


    I'll ask my ISP about it. But it seems my issue is not related to OMV5.


    Thank you!

  • Try different ports in OMV - something like, say, 18000 for http and 19000 for https. Then forward these ports through the router, but keep the same ports on the local and public side, avoiding 8080 and 8443 altogether.

    I think that's what gderf was getting at as well.

  • votdev

    Added the Label OMV 5.x
  • votdev

    Added the Label resolved

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!