haugene/transmission-openvpn WEBPROXY enabled, cannot connect to proxy.

  • Good evening,


    I am using the Haugene Transmission OpenVPN docker container to download torrents through my VPN. That process works just fine. I can download torrents through the VPN just fine. To download the torrents from certain providers, I need to login from the same public IP as my downloader is on. This container solves that problem by having a Webproxy which you point your browser to, and your HTTP traffic travels through the existing VPN tunnel in the container.


    I cannot get that to work for the life of me. Torrents in transmission are downloading properly from the VPN, but it doesn't seem like the proxy is running. I did a port scan of that machine and the 8888 port fails. I tried to connect using windows prosy settings and that failed. I have tried connecting using the FoxyProxy extension on chrome and it fails on the proxy. I checked the logs and I didn't see anything related to the proxy or any errors. Maybe I missed something?


    I built the container using the container section in Portainer so I don't have a stack or Docker run to post, but I have posted the inspect results inspect.txt from portainer. (too many characters for the body) and the logs. _transmission-openvpn_logs (2).txt


    Additionaly, I have -


    set the DNS to the google DNS servers

    Enabled the WEBproxy on port 8888

    Exposed port 8888

    set LOCAL_NETWORK=192.168.0.0/24

    tried changing to other ports

    tried with and without login and password for the proxy

    Ran curl -x http://192.168.0.3:8888 -H -L http://google.com and received (56) Recv failure: Connection reset by peer from the container console


    Is there anyone that has this currently running with no issues or someone willing to help me out? I am about to pull my hair out. I am not a great linux person either so my knowledge of commands etc is kind of limited.


    Help me OMV forum. You are my only hope.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!